Microphone stop working on picroft


Hello guys,

I have a problem with my picroft installation, after update to the newer version picroft stop listening the wake word and the mic level stay stuck in —7.86 without any change. I am using ps3 eye as microphone.

Do you have any ideas about why stop working?


Thanks for reporting this, @Dimitris_Soutas.
We’ve had several reports of this issue with Picroft on version 18.02.

Can I please confirm the following information:

  • Picroft on RPi3
  • Version 18.02
  • Microphone: PS Eye 3
  • Boots OK
  • Pairs OK
  • Listens to Wake Word
  • Does not respond to commands


Hi @KathyReid following you will find my input.


I also getting this error messages from mycroft.

21:07:00.483 - SKILLS - DEBUG - {“type”: “1017122086:TimeSkillupdate_display”, “data”: {}, “context”: null}
21:07:10.501 - SKILLS - DEBUG - {“type”: “1017122086:TimeSkillupdate_display”, “data”: {}, “context”: null}
21:07:16.508 - mycroft.skills.settings:_poll_skill_settings:401 - ERROR - HTTPSConnectionPool(host=‘api.mycroft.ai’, port=443): Read timed out. (read timeout=15)
21:07:16.512 - mycroft.skills.settings:_poll_skill_settings:402 - ERROR -
Traceback (most recent call last):
File “/usr/local/lib/python2.7/site-packages/mycroft_core-18.2.0-py2.7.egg/mycroft/skills/settings.py”, line 398, in _poll_skill_settings
File “/usr/local/lib/python2.7/site-packages/mycroft_core-18.2.0-py2.7.egg/mycroft/skills/settings.py”, line 372, in update_remote
skills_settings = self._request_my_settings(hashed_meta)
File “/usr/local/lib/python2.7/site-packages/mycroft_core-18.2.0-py2.7.egg/mycroft/skills/settings.py”, line 440, in _request_my_settings
settings = self._request_settings()
File “/usr/local/lib/python2.7/site-packages/mycroft_core-18.2.0-py2.7.egg/mycroft/skills/settings.py”, line 456, in _request_settings
"path": self._api_path
File “/usr/local/lib/python2.7/site-packages/mycroft_core-18.2.0-py2.7.egg/mycroft/api/init.py”, line 53, in request
return self.send(params)
File “/usr/local/lib/python2.7/site-packages/mycroft_core-18.2.0-py2.7.egg/mycroft/api/init.py”, line 78, in send
data=data, json=json, timeout=(3.05, 15))
File “/usr/local/lib/python2.7/site-packages/requests/api.py”, line 56, in request
return session.request(method=method, url=url, **kwargs)
File “/usr/local/lib/python2.7/site-packages/requests/sessions.py”, line 488, in request
resp = self.send(prep, **send_kwargs)
File “/usr/local/lib/python2.7/site-packages/requests/sessions.py”, line 609, in send
r = adapter.send(request, **kwargs)
File “/usr/local/lib/python2.7/site-packages/requests/adapters.py”, line 499, in send
raise ReadTimeout(e, request=request)
ReadTimeout: HTTPSConnectionPool(host=‘api.mycroft.ai’, port=443): Read timed out. (read timeout=15)
21:07:18.265 - mycroft.skills.settings:_request_my_settings:439 - DEBUG - getting skill settings from server for TimeSkill
21:07:18.274 - requests.packages.urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1):


OK, so those error messages are not related to microphone configuration. They are related to Mycroft trying to synchronize settings with the server - home.mycroft.ai - which occasionally times out.


I reinstall picroft on my rpi3 but I have the same error messages… any ideas?