Missing device settings like ssh public key?


I got my Mark II today, got through the set up and tested a few skills. That all went OK.

What I don’t appear to have is device settings beyond entering the name of my Mycroft, it’s “placement” in, then Geographical Location information and a link to click in the “Advanced Settings” that takes me to a page about mycroft.conf . I don’t see anywhere to put the ssh public key for example as mentioned in the ssh setup docs.

I’ve tried rebooting the device a few times in case it was a pairing issue and in case it was some sort of weird browser / account bug I’ve tried repeatedly logging out, clearing browser cache etc.

Does anyone know what might be wrong?


Once you’ve added your device to Account you can click the “edit” button and look all the way at the bottom of your browser screen (below the link you mentioned that leads to mycroft.conf). There is a paragraph that says:

“To access this device via the command line, provide the public SSH key for the computer that will be used to access the device below.”

There is a box below that that you paste your public SSH key into. Here’s my crude ASCII graphics-style approximation:

   -Public SSH Key--------------------------------------------------------------
   |  {Box here}                                                               |
   Paste the public SSH key of the computer used to to login to this device

Some people have reported that this feature is apparently not always available. Hopefully you won’t run into anything like that. Anyway, the above is what worked for me.

Thanks for the reply :slight_smile: Unfortunately I would appear to be one of the people that it isn’t always available for as it’s not visible on the page for me. I might try removing and re-adding my device to see if that changes anything :crossed_fingers:

It’s not there for me either. I just took the USB stick and put it in another Pi that I can log into and looked around. It’s kind of weird that people say to use the username mycroft. That name does not exist in /etc/passwd, only “pi” as usual with RPi. Similarly, the only directory under “home” is “pi”. I know that at least Picroft uses some virtual system that I am not too familiar with, but I’m still a bit mystified about all this. Any thoughts?

I’ve tried a couple things–first, I actually did find the home directory for Mycroft…it’s buried down a few levels. But when I put the public key there (in authorized_keys) that did not help. Then I unpaired it from my account and re-paired it. Nope. I may try again with a new account (my current one already has a PiCroft associated with it). But in the meantime, I have a $400 toy that can’t do anything that I bought it for. (I was planning to port my Hubitat skill to it so that I can change the lights etc in my office, but I can’t do that without being able to access it.) @gez-mycroft any ideas? This seems to be a common problem despite the fact that it should work.

So I finally got around to attempting removing the device and re-adding it via my Account’s devices page. But now I don’t get a new pairing code and I’m lost as to how to get a new one.

I’ve tried rebooting the device several times but the device continues through the boot process without going into the pairing code process. :weary:

EDIT: OK I flashed the USB with the latest stable image which started a new pairing process. But there is still no ssh box available. And the Hardware Version is “None” it may have already been like that but I’ve only just noticed it now.


I just got my Mark II today, and wanted to do a few things inside. A little research shows me that there is no password login possible, but that I should be able to give it a public key via my account on mycroft.ai. I also saw someone else long ago say that they did not have “Public Key” as something they could add on their account (using “Edit” on the device).

I’m in the same boat, but given that that topic stopped many months ago, someone must have found out how to do it! Any luck?

I’ve also found that most of the system skills (like reboot, shut down etc) are not there (“Try saying that another way”).

Has anyone had any luck with either of these?

That’s weird. I did not see Cosgrave’s post from just yesterday when I put in this one. I’m not sure if it did not appear or I just missed it. Ugg. Sorry.

So by now hopefully you saw messages that clarified that the Systems Skill you are referring to is not available in Dinkum (as of yet). First a Dinkum version of the Systems Skill needs to be created, converting the Classic Core Systems Skill, and that has not been done yet, and second some of the facilities may not be supported by Dinkum (as of yet).

1 Like

Thanks. I did not see that. Thanks.

All good. I’ve moved your post into that one. :slight_smile: