Mycroft Community Forum

My audio is so quiet

Hello!I ve just installed Picroft to my Rpi3.
The thing is that even the speaker volume is set to 9(the loudest) it is too quiet.I can barely hear it.
Another problem is that even if I reinstalled 3 times,the volume never comes out from the usb sound card,but always from the jack.
Last,my mic is working through the same USB card,but I can’t say if it is loud or quiet because of my speaker status.
I tried to modify my settings via “alsamixer” BUT when I press F4 or F6 it simply takes me to the cli again…
Any ideas??It seems quite promising…It’s a pity I cann’t use it.

Can you share some more details on your hardware setup - soundcard, amplifier, speaker?

Of course!So,my hardware is a rpi3,with a compatible usb sound card.(I use it to another rpi with no problems) and a speaker via the line in port.Thing is that on the setup I choose USB card and I don’t get an output.When I choose jack,the voice is so low,and it makes no difference if I choose 1,2 or even 9.
I ve changed the settings via alsamixer but it won’t save it.

Do you here the confirmation sound on the usb output? Does the terminal command aplay -l show your usb device? did you press F6 in alsamixer and did you choose the usb device and set master and/or pcm and/or Headphone and/or PCM to value of 88 (the beginning of the red zone)?

No I don’t hear it.Yes,aplay-l and arecord-l both show my usb card.I did press F6 in alsamixer.I ve chosen my USB card,but when I go again to alsamixer it still shows the default device…Every value is at 100,to be sure…thing is that outside picroft(linux command line) I can hear my recordings loud and clear…But when I m in the picroft I can’t…
And I m sure that my mic works correctly because it detects the wake up word and it answers.(in the command line)

Dear All,

just started to try out Mycroft.
I have run in the same issue here.
A fresh install on a linux mint: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal
First I had issues with the mic; input was too high and i solved it with the forum.
But now the response is ultra silence even with the setting audio out to max. So outside of mycroft the audio is loud now and within the application i can barely here the response.

FYI I am a newbie to linux but can run simple commands.

Any help is appreciated.

Call alsamixer from terminal, press F6 and choose your soundcard and have a look at the values (Speaker, Headphone, Master, etc.)resp. bring them to a higher level.

I’ve installed the latest Picroft on both an RP3+B and an RPi 4. Initially I also had no sound output via the 3.5mm jack to a Bose powered speaker. I used the process I’m about to describe on the RPi 4, then switched to the 3 after.

From having fiddled around with Ubuntu on old laptops, I’m aware that Linux can include pre-recorded .wav files located in /usr/share/sounds/alsa. That directory and some files are included down that path in the RPi OS that Picroft is built on.
To do straight testing and confirmation that the sound playback and volume settings are working, I use “aplay ./<file_in_above_directory.wav>” after changing in to that directory. The ./ is because I’m in the directory, and Linux is being told to look in that directory by that.
The sound volume achieved when doing that is the default audio channel playback volume since those are all recorded at a reasonable volume.

After that played very well, I then began following the suggestions in the Mycroft Documentation Troubleshooting-:>Audio Troubleshooting information to modify different system settings, including the “mycroft-config edit system” instructions, and I’ve had no sound issues since.