My Microphone is very insensitive


#1

Hi Everybody,

I have two mark-1 neither of which seems to hear me when i am more than about a meter away or unless i am literally yelling.
Messing with the soundmixer has not helped at all and i just can’t use mycroft this way. Am i really the only one? I would happily solder in a new mic but don’t know much about them and would rather avoid having an external one.


#2

@webshadow - Though our wakeword software is undergoing continuous development, this isn’t typical.

My Mark I units usually respond as long as I am within 10 feet or so, but I 100% believe that there is a problem.

I can think of several possible causes including the volume threshold, electrical interference in the power supply, improperly soldered components, improperly seated wiring harnesses, defective mics, etc.

Lets set up a time with @Darren-Mycroft and a support engineer and figure out what is wrong. We’d like to know so we can fix it remotely in other units ( if it is software ) or identify the problem and resolve it ( if it is hardware ).

Curious - are you using them as a user or are you developing for the platform, cuz our user experience is “Developer Pretty” ( i.e. Ugly ) right now.


#3

I am something in between i guess, been a Linuxnerd for quite some time
but not a coder. Since i already own a Google Home there is absolutely no need
for Mycroft to become polished in a rush. I knew what i was getting into but without
MC hearing me i could not continue …
I would gladly give you guys ssh-access or something like that … Unfortunately remoteshells
are hell, even with a fresh image there is severe lag and i have to reconnect constantly.
All i could see were some connections dropped by “ufw” but disabling it didn’t help.
The usual network based functions work alright like speech recognition or pulling weatherdata.
As far as i remember using a cable does not improve things. If you know about this problem and have a fix or idea i’d like to try them or connect a screen and put my linuxskills to use once again …


#4

@webshadow - @forslund has been working on a new image that might resolve some of these problems.

Ake - any word on a release date?


#5

It’s in testing right now. Should be released end of this week/Monday if nothing unexpected happens.


#6

I’m really looking forward to the update or do i have to reimage my mycroft?
I’d like to give helpful feedback and don’t mind starting fresh.


#7

First release will be image only so you’ll have to reimage the device. We’re looking at automating this, there are quite a number of tiny updates to make the road forward smoother and therefore a lot of tiny things that can go wrong in an automated procedure.


#8

I just want to chime in that I experience the same issue with my Mark I. I need to be within about 4 feet and speaking loud and clear for it to respond to me. Even 10 feet wouldn’t be that much of an improvement, but I understand that this is first prototype product. I enjoy tinkering and modifying things so I have no problem testing any improvements and modifications out. I would even consider swapping out the actual mic if it would bring a large improvement.


#9

I’m another user with this same microphone issue. My Mycroft Mark 1 just can’t seem to hear anything.

I admit he has been sitting on a shelf neglected for many months as nothing seemed to work on arrival. So over the holidays I found a little time to dig in and discovered that the updates had never been working. It seems it was stuck on 0.8.17 which had the update bug. I ssh’d in and did a manual upgrade via apt, but that seemed to totally screw things up.

Rather than waste time trying to work out what mess the upgrade had created, I copied the SD card image (mark-1_production_20171019_build-10) to a new 16GB microSD and booted from that. Still seemed to be deaf, so I left him alone to install any futher updates. That of course lead to him sitting there for hours saying “UPDATING”, apparently hung on something - but I couldn’t see anything in the logs. I used his control knob to initiate a reboot and he again said “UPDATING” for a while, but finally came back to normal - but still defa.

Now getting back to the microphone issue, I can ssh in and run mycroft-cli-client and the microphone level shown jumps around a bit near the 600 mark, but the movement does not in any way correspond to audible noise. I terminated the various mycroft and pulseaudio processes, and then use arecord -d 5 test-mic.wav to capture the microphone input. Playing it back with aplay gave nothing, and copying the file to my PC and viewing it in Audacity shows just a low level noise. I uploaded a small WAV file and was successful in playing that back with aplay (as expected, because I can head Mycroft talk). I tried a second recording with me yelling at Mycroft and tapping on the plastic housing, but still nothing.

Looking inside and comparing thing to the schematic, I see a bunch of missing components (microphone bias?) but they also appear to be missing from the BOM. I guess I can get out the oscilloscope and check if any signal is getting to the preamp and then into the WM8731 codec. Beyond that, I’d assume a software issue of some sort. Any thoughts before I spend more time on this?


#10

Good question @Kean, and excellent troubleshooting information.

Couple of things to confirm first;

  • Are you able to tell us which version of mycroft-core your Mark 1 is now running? apt-list | grep mycroft should do the trick?
  • Have you run a sudo apt-get upgrade && sudo apt-get update since burning the new image to Micro SD card?

If you’ve gone to all the trouble you have here, and that’s still not working then I think we need to look at a hardware replacement for you - if you email support@mycroft.ai and reference this conversation (URL) then we’ll be able to arrange that for you.

Kind regards,
Kathy


#11

Kathy, thanks for the quick response.

pi@mark_1:~ $ apt list | grep mycroft

WARNING: apt does not have a stable CLI interface yet. Use with caution in scripts.

mycroft-core/unknown,now 0.9.13 armhf [installed]
mycroft-mark-1/unknown,now 0.9.13 armhf [installed]
mycroft-picroft/unknown 0.9.13 armhf
mycroft-wifi-setup/unknown,now 0.2.3 armhf [installed]

I thought I’d leave it to do the manual update thing after my earlier experience, but I’ve just done an sudo apt update followed by sudo apt upgrade. There was a bunch of stuff upgradeable, including things like libavcodec* which could be relevant I imagine. Unfortunately during the unpacking of the updates the file system became read-only… So I think another re-image may be necessary, maybe on a new microsd. I’ve got plenty at my disposal, although this was a brand new one. I’ll have to try again later as it is way past bedtime now.

Seeing as I am based in Australia, that you’ve publish hardware docs, and that I’m an electronics and firmware engineer… I am not going to ask for a harware replacement. Instead I do kind of want to have a crack at fixing it myself. :smiley:

I mainly wanted to see if anyone else had tracked down potential causes of this issue as based on the above I’m apparently not the only one experiencing it.


#12

Ah, a RO filesystem is usually a sign of a failed Micro SD card.

Much respect for your fix-it attitude, kudos.

I’ll be at linux.conf.au in Sydney if you’re going in a couple weeks and want to catch up.

Best, Kathy


#13

Yes, agreed re the RO FS. I re-ran the upgrade (after a dpkg configure to cleanup after the failure) and it completed, but I may swap out the SD later and start again.

Mycroft still can’t hear me talk, but I can now see a response to me tapping on the case - i.e. I can see jumps from ~620 to ~720 in the mic level while running mycroft-cli-client. Mind you, just putting my hand near the enclosure without touching it causes the level to go up to ~700 as well.

I was hoping to get along to LCA 2018, but I have way too much work on right now. :frowning:


#14

Have you run the audio tests?


#15

Hi Kathy - Sorry, what audio tests are those?


#16

So, if you SSH to your Mark 1 and run sudo mycroft-client-cli then you will be able to see the microphone levels at the bottom right. What do they show?


#17

Not sure which of the two values corresponds to microphone level, but both numbers jump up a bit (max extra 100 units) when I tap loudly on the case. But when talking (or yelling) to him they hardly change other than the existing random noise they typically show.


#18

I did a test on my device and the mic levels I’m seeing are much higher.

5000-7000 when tapping the case and ~1500-2000 when speaking two meters from the device. Might very well be a hardware issue but you might want to run alsamixer, Press F6 select snd_rpi_proto Press F4 to select input devices and check that the Capture is set to 100. (my value is at 0)

/Åke


#19

Thanks @forslund - your typical values are good to know.
I’m sitting right next to the unit and there is 10-20 units of noise, and no appreciable difference when talking.

I’ve run alsamixer as described and the Capture value was 100. I confirmed that the settings were taking effect as I could enable the 20dB gain (Mic Boost) and immediately the mic levels shown increased dramatically (although by a factor of 10, not 100 as expected for 20dB).

So yeah, it certainly points to a hardware issue. I’ll do some inspection and testing soon and report back.

I’ll also note here for any others that come along later that I had to set TERM=putty (from default of ansi) to get the display and function keys to work in alsamixer, and that also fixed the slightly scrambled display I had in mycroft-client-cli.