Mycroft Community Forum

My skill does not work

Hi, I created today my first Skill, but often Mycroft doesn’t even recognize it, also when I write exactly the sentence, I wrote in the intent file. And if it recognizes there comes:

communication load status 286 - Skill failed to load

I hope someone can help me.
Thank you!

You should have a few more lines before that log entry that might help point you at what’s going on.

Searching for i am going from Paris to Rome
Removing event fallback-query.mycroftai:QuestionQueryTimeout
Removing event fallback-query.mycroftai:QuestionQueryTimeout
Removing event fallback-query.mycroftai:QuestionQueryTimeout
Removing event fallback-query.mycroftai:QuestionQueryTimeout
Removing event fallback-query.mycroftai:QuestionQueryTimeout
2020-05-05 11:20:03.252 | INFO | 3071 | QuestionsAnswersSkill | Timeout occured check responses
2020-05-05 11:20:08.493 | INFO | 3071 | ConfigurationSkill | Remote configuration updated
2020-05-05 11:20:13.672 | INFO | 3071 | main:shutdown:265 | Shutting down skill service
2020-05-05 11:20:14.127 | ERROR | 3071 | mycroft.skills.mycroft_skill.mycroft_skill:default_shutdown:1229 | Skill specific shutdown function encountered an error: NameError(“name ‘WebsocketClient’ is not defined”)
Removing event mycroft-reminder.mycroftai:reminder
Removing event mycroft-date-time.mycroftai:TimeSkillupdate_display
Removing event mycroft-configuration.mycroftai:UpdateRemote
Removing event mycroft-configuration.mycroftai:ConfigurationSkillupdate_remote
Removing event mycroft-weather.mycroftai:precache1
Removing event mycroft-weather.mycroftai:precache2
Removing event mycroft-weather.mycroftai:precache3
2020-05-05 11:20:14.965 | ERROR | 3071 | mycroft.skills.mycroft_skill.mycroft_skill:default_shutdown:1229 | Skill specific shutdown function encountered an error: AttributeError("‘WolframAlphaSkill’ object has no attribute ‘remove_fallback’")
Removing event mycroft-version-checker.mycroftai:DailyVersionCheck
2020-05-05 11:20:16.462 | INFO | 3071 | Playback Control Skill | Audio service status: {}

That is the log, when it doesn’t recognize my skill.
Thank you for your help!

Any chance you could provide a link to your code to have a look?

Sure, here is the GitHub link: https://github.com/durokaki26/Huitas-Skill

I made everything a comment, what I wrote in the Code so that that does not affect.