Mycroft Community Forum

Mycroft cant understand voice command. all command workd great in cli

I have set up the Mycroft on Linux desktop. All the command on CLI works great but when I speak in front of mic it doesn’t understand anything. The microphone level also changes when I speak. Please help me to solve the problem.

Did you take a look into the documentation? There is a chapter for audio troubleshooting

Hey there, I’d also double check if your computer supports AVX:
https://mycroft-ai.gitbook.io/docs/using-mycroft-ai/get-mycroft/linux#system-requirements

If not then Precise our main Wake Word engine won’t work. You can switch to PocketSphinx and see how that performs for you. Just type into the CLI: “set the listener to PocketSphinx”

I have checked with the command “grep avx /proc/cpuinfo” and my computer supports AVX.
When I setup Mycroft on my computer I have run “git clone https://github.com/MycroftAI/mycroft-core.git” without SUDO.
Can this make any permission issue while using a microphone . I have also tested the speaker and microphone using “start-mycroft.sh audiotest” with success.

You should not use sudo when cloning the repo so that shouldn’t cause any issues. Did you use sudo for other commands like running dev_setup.sh?

It would be worth trying to play a Mycroft video from Youtube and see if that will trigger the wake word. This can indicate if the wake word engine is struggling to understand you or not working altogether.

Hi,
Just to avoid all the confusion. I have removed the Mycroft and install it again in the Linux environment. but still facing the same problem. Sharing with you the lines from 1 to 103 of voice.log file. Please go through it and suggest to me if, is there a need to make any changes in code or settings?
Voice log URL: https://justpaste.it/3tbso

Hey there, it looks like it is detecting the wake word, and here you can see it heard “from the guy”

2019-12-11 21:16:05.767 | INFO | 3059 | main:handle_wakeword:59 | Wakeword Detected: hey mycroft
2019-12-11 21:16:06.196 | INFO | 3059 | main:handle_record_begin:37 | Begin Recording…
2019-12-11 21:16:07.608 | INFO | 3059 | main:handle_record_end:43 | End Recording…
2019-12-11 21:16:11.982 | INFO | 3059 | main:handle_utterance:64 | Utterance: [‘from the guy’]

Do you hear the wake acknowledgement tone when you say “Hey Mycroft”? It uses this sound by default.

When you say it doesn’t understand anything do you mean:

  1. It doesn’t seem to wake up when you say “Hey Mycroft”?
  2. It wakes but doesn’t transcribes your speech to text?
  3. Your speech is transcribed but the system doesn’t respond properly?

I am facing first case:
1)It doesn’t seem to wake up when you say “Hey Mycroft”?
and the link for "this sound "having 0.00 sec audio so it is not working .

Ok so definitely dealing with the wake word spotter.

The audio clip is less than a second so gets reported as 0. You can right-click and save-as to your computer which should work. But if it was making the sound you would hear it from Mycroft anyway.

The logs you posted showed that it triggered at least once which indicates that Precise (the wake word engine) is operating. Did you try playing the youtube clip from above to see if other voices could trigger it?

One other thing to try is reducing the level of your microphone, you can often do this in your computers settings. Otherwise you can run:
alsamixer
then press F4 for “Capture” and use your arrow keys to change it.

If the level is too high, it can be difficult for the model to catch the wake word. I keep mine down around 40%.