Build an open future with us.

Invest in Mycroft and become a community partner.

Mycroft changes conf file?


#1

I am successfully running Mycroft on a Pi 3B without too much difficulty. I have now changed the configuration file several times to use the “slt” voice, but it keeps changing back without my input.

Any thoughts as to why this is happening?


How is support coming on the Pi 3 B+?
#2

How are you setting which voice it uses?


#3

I’m away from my computer for the day, and I don’t remember the file name (mycroft.conf), but I changed it using nano, saved and rebooted. This worked and I had the slt voice. Waited a few days and the voice changed back. The file I changed didn’t have my original changes.

It’s really odd.


#4

mycroft.conf uses a hierarchical system, where personal settings override system settings. If you overrode the system settings, but your personal settings were the same, then it’s possible that the personal settings are overriding changes you made to the system.


#5

I made changes to /etc/mycroft/mycroft.conf, the system settings. I didn’t change the personal setting at all.

This worked at first, but after some time I got the AP voice again. After checking the /etc/mycroft/mycroft.conf file, my previous changes were gone.

I wonder if it gets overwritten at some point? I’ll make the changes in the personal mycroft.conf file and see if that happens again.

I’m a long-time Linux user, so it’s a little odd to have sporadic changes.


#6

Good clarification, thanks @Dataminer-x.

mycroft.conf definitely gets written to by Mycroft; it’s how we are able to store preferences offline.

I’m going to see if my colleague @forslund has any thoughts on this one?


#7

There are a couple of things that get written to the system config during package upgrades.

mimic binary path is set to default value and the wakeword engine for “Hey Mycroft” is set to precise. For the picroft it also sets the default wav_play command to aplay.

It shouldn’t affect the tts->mimic->voice setting (as far as I can see at least). I’ll do some tests here.


#8

No worries, I changed it in my personal mycroft.conf. We’ll see if that sticks.

I’m not used to getting updates that I didn’t initiate, but I certainly understand the need for it in this case.

Let me know if you want to see any of my changes.