Mycroft-cli-client crashes


#1

I try to launch mycroft-cli-client and it keeps saying that the connection is refused. Here are some logs:

> 2019-10-11 16:12:18.612 | INFO     |  1136 | mycroft.messagebus.load_config:load_message_bus_config:33 | Loading message bus configs
> oxy_type)
>            File "/home/pi/mycroft-core/.venv/lib/python3.5/site-packages/websocket/_core.py", line 220, in connect
>                                       options.pop('socket', None))
>                                                                     File "/home/pi/mycroft-core/.venv/lib/python3.5/site-packages/websocket/_http.py", line 120, in connect
>                sock = _open_socket(addrinfo_list, options.sockopt, options.timeout)
>      File "/home/pi/mycroft-core/.venv/lib/python3.5/site-packages/websocket/_http.py", line 190, in _open_socket
>                                      raise err
>                                                 File "/home/pi/mycroft-core/.venv/lib/python3.5/site-packages/websocket/_http.py", line 170, in _open_socket
>                                                                                 sock.connect(address)
>                      ConnectionRefusedError: [Errno 111] Connection refused
>                                                                            2019-10-11 16:18:34.560 | ERROR    |  1136 | mycroft.messagebus.client.client:on_error:88 | Exception closing websocket: ConnectionRefusedError(111, 'Connection refused')
>      2019-10-11 16:18:34.589 | WARNING  |  1136 | mycroft.messagebus.client.client:on_error:91 | Message Bus Client will reconnect in 60 seconds.

I have almost no experience in programming.


#2

Hi there,

This command presumes the services are running already. Instead can you try:
mycroft-start debug