Mycroft CLI shows no Mic, test_microphone working


#21

Where are we with this microphone problem? Are we waiting for a fix for a known problem, as the default.pa fix above is not working for me.

Mycroft is working fine. If I type commands into the cli they get actioned as expected and speech is working fine, but nothing showing on the mic level. Test-microphone works perfectly.

Using a raspberry pi with PS3 eye, which worked fine with alexapi, but Id rather use mycroft.

Am I missing something? Here is the end of my default.pa (I have commented out the “suspend” bit too).

### Make some devices default
set-default-sink alsa_output.0.analog-stereo.monitor
set-default-source alsa_input.usb-OmniVision_Technologies__Inc._USB_Camera-B4.09.24.1-01-CameraB409241.analog-4-channel-input

Many thanks for any help. Happy to wait if that is the only option.


#22

Thanks, we’re currently testing a new Picroft image right now, @boik99.
You can test it for yourself at https://mycroft.ai/to/picroft-unstable

Kind regards, Kathy


#23

Excellent, thanks Kathy. I shall give it a go and report back. Might not be til next week as we have our grandsons 1st birthday this weekend.


#24

A very happy birthday to your grandson, @boik99! :cake: :candle:


#25

Thanks Kathy. Maybe I should get Mycroft to sing Happy Birthday to him!


#26

Kathy, some good news! Just had a quick 10 minute play with the unstable version and wake word detection works out of the box. However, I am getting the following error:

15:52:46.850 - mycroft.client.speech.listener:transcribe:175 - WARNING - Access Denied at mycroft.ai

I hasn’t offered me a paring code, despite a couple of reboots. Have I missed something?

Thanks for your help so far.


#27

Bit more from the logs:16:26:34.438 - mycroft.client.speech.listener:transcribe:175 - WARNING - Access Denied at mycroft.ai
16:26:34.443 - mycroft.client.speech.main:handle_utterance:61 - INFO - Utterance: [‘pair my device’]
16:26:34.466 - requests.packages.urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai

16:26:35.225 - requests.packages.urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai
16:26:35.834 - requests.packages.urllib3.connectionpool - DEBUG - https://api.mycroft.ai:443 "GET /v1/auth/token HTTP/1.1" 401 38
~~~~ycroft.metrics:report_metric:42 - ERROR - Metric couldn't be uploaded, due to a network error (The supplied authentication is invalid)

As an aside, the mic-level does not work on my first cli connection, but works perfectly if I start another session. Not a problem for me, juct thought it might mean something to you.

#28

Any suggestions with the non-pairing issue Kathy? Seem to have taken one step forward and two steps back. I’ve check that the paring skill is there, and ran “msm default” just in case. Sort of out of ideas now.


#29

Hey there @boik99 - did you remove any previous Devices that were created in home.mycroft.ai? That’s the only thing I can think of. Or, the microphone is not working, so the Pairing code is not being spoken - ie the pairing code exists but we can’t hear it.


#30

Hi Kathy. Yes, old device was removed before I built the new image. Mycroft is hearing and responding to “Hey Mycroft”, and I hear the little beep. Also it speaks out when it first starts up about “Mycroft is updating, please wait” or something, so I think that both microphone and speaker are working.

I think if it was offering a pairing code it would be in the logs wouldn’t it? I have been through all the logs and the above is the only reference to pairing that I can see.

I can nuke the SDcard and try again, just in case it’s a one off.


#31

OK, got there in the end. Stable version has non-working microphone for me. The unstable img you pointed me at wasn’t interested in pairing although the mic worked perfectly. I took this image and pointed apt-sources at unstable and did an upgrade, and this morning Mycroft was nagging me to pair my device. Successfully paired and now working as expected. Yippeeee!!

Not sure if my experiences are any use to you guys, but I’ve certainly learnt a lot after ploughing through every log and file I could find.


#32

oh that is great news, @boik99. I am going to ping @steve.penrod here, as he has been tracking this one a while.


#33

I’m in very much the same boat as the OP - test_microphone works but Mycroft CLI isn’t hearing anything. This thread has kind of wandered away from the original concern though and has also seemed to go a bit dark. Searching elsewhere I see others have this problem. I tried setting default source in /etc/pulse/default.pa but still no joy! Note that, like the OP, I also had all of this working (speakers and mic) only to see the mic part mysteriously stop working. I’ve reproduced this twice now by just reinstalling from the flash image - eventually the mic stops working in mycroft but does continue to work in test_microphone (for example).

Any further thoughts on correcting this problem in some other way besides moving to the unstable channel?


#34

@bucketman if you use the pactl/pacmd to set the source and restart the services, this should generally get you working. I would for the most part recommend avoiding editing the default.pa file.