Mycroft detects wake word but understands nothing after that


#1

Hello everyone! Firstly, thank you for creating and helping maintain one of the best open-source projects I have ever worked on! This is my first post on the forum. Please excuse my amateurism, if any.

I recently installed Mycroft v18.8.13 on my Ubuntu Desktop (16.04).

Everything seemed to be working fine, until I decided to check out the alarm skill. I set a test alarm, which it duly set. But the alarm did not ring at the set time. This was followed by constant error messages from the alarm-skill. After much trying, I deleted that skill, and reran the cli. No more alarm-skill errors followed.

However, now when I try speaking, Mycroft catches the wake word, attempts to record, but is not able to transcribe, understand or respond to anything.

I get the following errors after every utterance of the wake word:
mycroft.client.speech.listener:transcribe:183 - INFO - no words were transcribed
mycroft.client.speech.listener:transcribe:186 - ERROR - Speech Recognition could not understand audio

I would appreciate any help from you guys, as even though a few hours old into Mycroft, I seem to love it :slight_smile:


#2

I have no idea….but it could be your issues arent related, but ust happend on same time.

First restart all mycroft services to make sure they are running. something like:

stop-mycroft.sh
start-mycroft.sh all (or debug)

#3

Hey there,

It sounds like some funky things are going on. We’ve pushed some updates to the alarm-skill in the last few days so I am hoping the new version won’t have the same problems.

If you run mycroft-start debug
are you able to run commands and get a response by typing them in?

So that we can checkout your logs and what might be going on, can you enter “create a support ticket”. This will upload your logs to termbin.com and email you a link.


#4

Thank you for your reply @andlo. I was able to solve it eventually by restarting Mycroft services. I appreciate your reply.


#5

Hello @gez-mycroft, I was able to solve the issue, by eventually restarting Mycroft services. Thank you for your response! I feel I should have tried more before posting it as a question here. I appreciate your reply :slight_smile:


#6

No worries at all, just glad it’s working :slight_smile: