Mycroft Community Forum

Mycroft doesn't understand home assistant commands after installing duckdns

Hi Everyone,

Sorry for the long topic. I have Mycroft running on RP3, and Home Assistant running on another RP3. I had both working together just fine… until I set up some port forwarding on my router and set up duckdns for external access to my home assistant. It looks like my router allows for NAT loopback (from my pc i ping the duckdns address and it returns my external ip address).

Any suggestions on what might be wrong?

Thanks!

make sure to change the setting in your home assistant skill to use ssl and use the xxx.duckdns.org as your host

Thanks for the response!

I have xxx.duckdns.org (xxx being the name I created on duckdns) as my host. I selected use ssl, and enable conversation component. I have the long lived access tokens I created in Home-Assitant copy and pasted in. I still get Mycroft saying he doesn’t understand my command to turn off the light, that he previously understood before duckdns.

Check the logs to see if there’s anything helpful (/var/log/mycroft/, skills and voice logs probably most useful)

If mycroft says something like “I don’t understand”, it probably means your homeassistant skill is not installed or loaded properly. if it was just your duckdns that was misconfigured, it would say something like "I can’t reach homeassistant on https://xxx.duckdns.org:8123".
Like baconator said, you might find some usefull hints if the skill failed to load in the logs.

1 Like

Thanks guys, just following up on this. I did get it working…

I ended up reinstalling pycroft, then installed the python package fuzzywuzzy. I then installed home assistant. After that, I configured the settings for the skill and it did not work. A reboot of mycroft and it is talking to homeassistant now.

Thanks!