Build an open future with us.

Invest in Mycroft and become a community partner.

Mycroft for linux


#1

Hey,

A first time user here.I am trying Mycroft for linux- ubuntu 18.04. I have cloned the repo and run the dev_setup.sh file.After that I am trying-

./start-mycroft.sh cli

I am getting the error -
12:01:58.029 - mycroft.configuration.config:load_local:129 - DEBUG - Configuration ‘/var/tmp/mycroft_web_cache.json’ not found
12:01:58.101 - mycroft.configuration.config:load_local:129 - DEBUG - Configuration ‘/etc/mycroft/mycroft.conf’ not found

Is there a way to create these files manually?


#2

Hi there @SWAPAN_JAIN, great to have you here and welcome.
It’s possible to create these files manually, however I would recommend running ./dev_setup.sh again (without rebuilding mimic) - as the script will try and create them again. Take a note while ./dev_setup.sh is running to see if there are any errors while it is running.

Kind regards,
Kathy


#3

How do I run the shell file dev_setup.sh without rebuilding mimic?


#4

When you run ./dev_setup.sh, the command line will ask you whether you want to rebuild mimic or not - it detects whether mimic has already been compiled.


#5

I tried running the dev_setup.sh without rebuilding the mimic but I have the same error.
Also it shows connection refused.


#6

Also after running dev_setup.sh, I can’t find mycroft_web_cache.json file anywhere in mycroft local repo. Need help.


#7

@SWAPAN_JAIN - could you send an email to hello@mycroft.ai? That will open a ticket on our end and we can start doing some troubleshooting.

Thanks
-Darren


#8

@Darren-Mycroft no need for that,It was a mistake from my side.i couldn’t hear the registration code earlier.


#9

Great! Glad to know the issue resolved itself!

Don’t hesitate to reach back out if you need any other help.

-D