Mycroft "having trouble communicating with Mycroft servers" after upgrade to 21.2.2


I’m running Picroft on a Raspberry Pi 4B and it has worked great for a while. I periodically run the following to restart Mycroft and get updates:

/home/pi/mycroft-core/ all
/home/pi/mycroft-core/ all

After the most recent update, Mycroft has been telling me “Im having trouble communicating with the Mycroft servers. Please give me a few minutes before trying to speak to me.”

I know the Pi has internet because im able to open the mycroft-cli-client and type commands like “play the news” which result in an NPR stream playing as expected. In the mycroft-cli-client I can see Mycroft attempting to pull down skill configurations and failing with a “Failed to upload skill settings meta …”

So it seems like any attempts to connect to Mycroft’s servers are failing (for speech processing or skills updates). And this definitely started with the recent upgrade to 21.2.2. Unfortunately Im not sure what version I was on before this, probably just the most recent predecessor.

I’ve tried rebooting the Pi and starting and stopping all Mycroft Services, but this does not seem to help.

Any help is greatly appreciated!

To support troubleshooting I stopped all Mycroft services, removed existing log files, and started the services again. Here are links to the newly created log files:

Hey sorry, I’ve been on leave and didn’t see this before.

It looks like you’re getting 500 errors returned from the server which means something is failing there rather than on device. I haven’t heard of anyone else having trouble though which suggests that it’s isolated to your account.

Is your account at using the same email address as you have here on the Forums?

A quick fix might be to re-pair it with our backend by removing (or just moving) your local identity file, then reboot.

mv ~/.config/mycroft/identity/identity2.json ~/identity2.json.backup
systemctl reboot

However I’m interested as to what has gone wrong.

Hi @gez-mycroft, I hope you had some nice time off!

Yes, the email should be the same.

I did remove the device (my only one) from, stopped, then restarted all Mycroft services, but that did not seem to do anything (Mycroft still thinks it is paired).

Let me try your suggested “move identity2.json and systemctl reboot”. Standby…

@gez-mycroft I moved identity2.json out of ~/.config/mycroft/identity and did a sudo systemctl reboot I’ve verified there is nothing in that directory but Mycroft still thinks he is paired.

In mycroft-cli-client I type, “pair with” and he responds, “Thanks but im already paired”.

And I’m still getting a 500 error in response to any speech recognition requests. Basic skills like “play the news” are woking as long as i type the command directly into the CLI.

Ah this will be the problem. If you removed the device from your online account, the server will be rejecting requests.

Got tickets for these already on our backlog but on our end we need to:

  1. Improve the process of removing a device so that the device stops thinking it’s paired
  2. Improve the error message rather than a generic 500 error

Have you got anything at ~/.mycroft/identity/? If so remove that too.

@gez-mycroft I only removed the device from my online account yesterday afternoon, but this problem has been occurring all week. Before deleting the device was showing this device as “disconnected”.

That directory does not seem to exist:

Any other ideas for now? or is this something that has to be fixed on the back end? Im hoping to not have to reinstall the Picroft OS because i’ve installed some other stuff on this one that would be annoying to set back up again.

You don’t ever want your server to return 500 - “Internal server error”. But we all know how programming computers goes :neutral_face:

I sometimes write traps in my code that say in effect “I know this can never happen.”, but just in cast it does, 500 is returned and the location of the code.

-Mike M

Hi @gez-mycroft, I understand it’s not a priority, but any updates on this?? I miss my Mycroft :’(

I’d be happy to help troubleshoot from my end, just let me know what you need.