Mycroft Community Forum

Mycroft II - wifi cannot be connected

I have received Mycroft II today, assembly was OK, downloading the image, starting, all fine. However when it comes to WiFi connection, didn’t respond after setting using my mobile phone. after restarting there was no MYCROFT network. I had to re-image the USB drive. Second time I use computer to setup WiFi. it failed authentication twice, then the same story. This time I realized that a file for the selected WIFI is created in awconnect directory. deleting that file also didn’t help. the only way I can get the MYCROFT network is with re-imaging the USB disk.
Also connecting a network cable doesn’t help, as still asking to connect to WiFi .

Edit: Currently I am in China

Hi rooz,

Sorry to hear you’re having some trouble with getting your new Dev Kit connected to Wifi.

Can I double check which image you are using? The latest should be version 12: https://mycroft.ai/to/mark-ii-stable

If the Mark II can’t connect to the wifi, it should initiate the MYCROFT hotspot. It sounds like it’s correctly creating a connection which you found in: /etc/NetworkManager/system-connections/

Is there a chance it’s connecting to this network but can’t reach the internet?

The way that Mycroft determines whether it’s connected to the internet can also be configured. The default configuration is:

  // URIs to use for testing network connection.
  "network_tests": {
    "dns_primary": "8.8.8.8",
    "dns_secondary": "8.8.4.4",
    "web_url": "https://www.google.com",
    "ncsi_endpoint": "http://www.msftncsi.com/ncsi.txt",
    "ncsi_expected_text": "Microsoft NCSI"
  },

Are any of these blocked on your local network or upstream? You can set them to your own preferred values.

Thanks for your reply.
1- By waiting for 12 hours overnight finally it was connected and I managed to register it. Its up and running. Voice recognition is great, responds took up to 30-40 seconds. Its great if I can make it faster responding to questions

2- yes from the list of testing network, google is blocked in here. " ```
http://www.msftncsi.com/ncsi.txt” also is redirected to google. Anything to google, Facebook, YouTube, and Wikipedia, I should avoid.

3- Vpn is good solution, but usually they cannot stay all the time connected and need manually updated and reconnected.

1 Like

30-40 seconds is quite extreme. Would be interesting to see what part of the process is taking so long.

If it’s the STT then you could try a localized STT service.

Still connection is a big issue. on booting especially, it takes many hours Mark II to realize that internet is connected. Sometimes for a whole day it cannot be connected at all, or waiting for WIFI connection. Then it is waiting for a WIFI connection while MYCROFT network is not running, or not accessible.

Do you thing I should change ```URIs to use for testing to one accessible with ones in China? if yes, where can I make those changes to URIs?

Yeah definitely

You want to use the mycroft-config tool:

mycroft-config edit user

By default that will have:

{
  "max_allowed_core_version": 21.2
}

and you want to add the network_tests settings block from above eg

{
  "max_allowed_core_version": 21.2,
  "network_tests": {
    "dns_primary": "8.8.8.8",
    "dns_secondary": "8.8.4.4",
    "web_url": "http://www.baidu.com/",
    "ncsi_endpoint": "http://www.msftncsi.com/ncsi.txt",
    "ncsi_expected_text": "Microsoft NCSI"
  }
}

You’d need to find some good DNS servers to ping, and the NCSI endpoint should be a text only resource. All we do is make a request of that URI and check the response against the ncsi_expected_text value.

EDIT: When you’re done - hit Ctrl+x to exit and it will prompt you to save the file.

Sorry for the delay in responding. I made changes as above. With a good internet connection respond time has changed to 10-15 seconds . However at rebooting or after a disconnection it takes hours to be connected again. Maybe its because of connection timeout settings. May need to increase it.