Mycroft Mark 1 screens not working anymore after update

I just updated using apt-get dist-upgrade after SSHing on my Mark 1 as it was stuck on 0.8.17 since I received it.

After update and reboot, system is working, Mycroft is listening and speaking, but eyes and screen are both off and not working anymore.

How can I fix this?

Thanks for your help.

Hi @kalon33, thanks for flagging this with us. There are a couple of things to try here.

  • Firstly, given you’re comfortable doing apt-get on the command line, I’m going to assume you’re comfortable with log files. Can you please have a read through the mycroft-update.log file at /var/log and see if there are any errors?
  • If so, try running sudo apt-get update and identify if there are any other packages that need updating. dist-upgrade will try and be smart and prioritize certain packages for update to resolve conflicts.
  • Eyes and screen both being off indicate a possible LED display issue - if they were working previously it’s unlikely hardware failure, but more likely a dependency on which the display relies.

Please let us know how you go.
Kind regards,

Hi @KathyReid, thanks for your help.

  • Except these two warnings from dpkg, there’s nothing unusual for a apt-get log:
    dpkg: warning: 'ldconfig' not found in PATH or not executable dpkg: warning: 'start-stop-daemon' not found in PATH or not executable dpkg: error: 2 expected programs not found in PATH or not executable Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
  • According to apt-get, there’s no package to upgrade. Is there a specific package, config files or something for the display?
  • What’s weird about this is that they were working perfectly just before running apt-get dist-upgrade, eyes were still lit immediately after update, and a reboot switched them off, and they didn’t turn on (both screen and eyes) since.

Best regards,

@kalon33 OK, we’re going to try an update of the Mark 1 package. Do
apt-get install -f mycroft-mark-1
and let me know the output of

OK, just launched it, will give you the result at the end, but mycroft-mark-1 and mycroft-wifi-setup were, for an unknown reason, not installed on my Mark 1.

Wait, I’m not sure of that, because I don’t remember if apt-get would say it’s a reinstall or just an install.

here is the apt-get log:
sudo apt-get install -f mycroft-mark-1 Reading package lists... Done Building dependency tree Reading state information... Done The following extra packages will be installed: mycroft-wifi-setup The following NEW packages will be installed: mycroft-mark-1 mycroft-wifi-setup 0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded. Need to get 55.0 MB of archives. After this operation, 26.6 kB of additional disk space will be used. Do you want to continue? [Y/n] y Get:1 debian/main mycroft-wifi-setup armhf 0.1.4 [55.0 MB] Get:2 debian/main mycroft-mark-1 armhf 0.9.1 [2,198 B] Fetched 55.0 MB in 49s (1,119 kB/s) Selecting previously unselected package mycroft-wifi-setup. (Reading database ... 41836 files and directories currently installed.) Preparing to unpack .../mycroft-wifi-setup_0.1.4_armhf.deb ... Unpacking mycroft-wifi-setup (0.1.4) ... Selecting previously unselected package mycroft-mark-1. Preparing to unpack .../mycroft-mark-1_0.9.1_armhf.deb ... Unpacking mycroft-mark-1 (0.9.1) ... Processing triggers for systemd (215-17+deb8u7) ... Setting up mycroft-wifi-setup (0.1.4) ... Initializing init script for mycroft-wifi-setup-client Starting Mycroft service mycroft-wifi-setup-client Setting up mycroft-mark-1 (0.9.1) ...

1 Like

And for good measure let’s do a reboot by pressing the top button for 2 seconds, and rotating the button till you see “REBOOT”, then press the button.

As the screen was off, I couldn’t, but I restarted using the good old sudo reboot using SSH, and now eyes are lit and screen is working now :slight_smile:

Thanks for your help!

Are the eyes moving now when mycroft is active or not?

Best regards,


1 Like

Also, is there some progress with other languages support (notably French, Italian…)?

Thanks again :slight_smile:

That’s great! Thanks for confirming @kalon33.
The eyes blink when a command is issued, but don’t move.

Regarding language support, that’s coming along slowly, but you can read more here:

Kind regards,