Mycroft Marketplace improvements needed re. Mycroft II

  1. Please update the Mycroft Marketplaces in recognition that the default application stack on Mycroft II (dinkum) is not compatible with the existing Skills. Many Skills are flagged as being “Compatible” with Mycroft II, which may be accurate as far as the hardware is concerned, but which is not accurate with the software shipped with the Mycroft II.
  2. Add a filter to the list of available Skills, allowing the user to select Skills by hardware & application stack (ie., Mycroft II/sandbox, or Mycroft II/dinkum). If a user has registered just a single device on mycroft.ai and it is a Mycroft II, the filter should default to “Mycroft II/dinkum” to eliminate the confusion and unmet expectations that occur when presented with a list of incompatible skills.
3 Likes

Thanks for raising this. I’ve just moved it over to the Mark II Feature Request category so we can keep track of it with other improvements.

For the moment, only Skills available on the Mark II Dinkum image should be considered compatible. And anything listed as Mark II compatible on the Marketplace should work on the Classic Core Sandbox image.