Mycroft now available as Raspberry Pi image


#21

I have some secondary school students that want to set up Mycroft using the Pi image. It seems to boot up fine, but they are getting a prompt in the terminal to search for a Mycroft wi-fi hotspot, which nobody seems to be able to find. The are running a Pi2 with a USB wi-fi adapter, though they we are unsure if it is capable of acting as an ad-hoc network. Is there a recommended wi-fi adapter to use?


#22

@Dan_Andrews,

I’ll have to try this with a Pi2, I only have Pi3s handy at the moment. With a Pi3, the onboard Wifi gets “split” during that initial pairing process. So there is a chance that a USB wifi won’t work. Just to be clear, if you use a laptop or a phone and pull up the list of available Wifi networks, you don’t see a network called “MYCROFT” – correct?

As a work around you can either of two things to get this going:

Plug the unit in using Ethernet.
We just need a network connection, it doesn’t have to be Wifi.

Manually configure the wifi.

It isn’t too difficult if you have the Pi2 plugged in to a keyboard and HDMI monitor:

  • Hit Ctrl+C to get to the command line
  • Type: sudo nano /etc/wpa_supplicant/wpa_supplicant.conf
  • Arrow-key down to the bottom of the file and enter something like this:
    network={
            ssid="MyNetworkSSID"
            psk="mypassword"
    }

(of course, use your own SSID and password :slight_smile: )

  • Hit Ctrl+X to exit and Y,Enter to save your change.
  • Type: sudo reboot now

Let me know if this works for you!


Mycroft on Pi 2 internet connect problem
#23

I’ve tried my image on the pi3 and pi zero W, and still have not gotten the wifi to work. It does get an internet connection through ethernet, though, however when it does and I try to register the device, it goes through the process and then after a reboot, it wants to register again. I have tried manually setting up the wifi as @Dan_Andrews said, however it still will not connect.
Also, I’m intrigued by another commenter’s idea of having a single image of Raspian with mycroft built in. I’m going to try to make that happen (if someone already has, please do let me know).
I can, however confirm that Mycroft does work as well on the pi zero w as it does on the pi 3.


#24

Also, I understand that the image is based on Raspian, however unless I’m just not getting all the way through the setup, I haven’t encountered a GUI yet, it’s been all command line. I’m actually aiming for an interface that involves having a touchscreen connected, so Mycroft can show information as well as speak it. I’ve seen some screenshots of Mycroft running in a window on a Linux build, and was inspired by that. Though eventually I intend to make the Mycroft interface the entirety of the GUI shell.


#25

Hey Lucien,

The Picroft image is based on Raspian Lite, so no GUI.

We did have an issue a few weeks ago where you would have to re-register the device after a reboot, but that should be fixed with the newest image file and version.

Also, thanks for the update on the Pi Zero W. It’s something we’ve been wondering about and wanting to test, but everywhere is sold out.


#26

steve.penrod I updated wpa_supplicant.conf and it works, easy as Pi. Thanks very much!


#27

I’m glad it worked for you, @Dan_Andrews!

@Lucien_Storm, I have doubts that even a Pi3 can handle a GUI and running Mycroft at the same time. I fear there just isn’t quite enough computing power there to give you the experience you want. But I’d be happy to be proven wrong!


#28

I have a Pi3 running GUI and Alexa/AVS at the same time, with no performance issues. It’s a very Echo-like experience. Why would Mycroft impose a heavier load?

I should mention that I’m using the Conexant CX0921 mic and audio board to handle wake-word detection, which relieves the mainboard of the need to process all incoming audio except when triggered by the Conexant board. But others have got AVS working satisfactorily on the Pi3 even while running a wakeWordAgent on the main CPU via full Raspbian GUI.


#29

Thank you for the clarification. I had not tried the Lite version before. I’m still going to experiment with a GUI, and see if I can get Mycroft core integrated. Also, I think some of my Wifi issues may have something to do with the login splash page (because it’s a public wifi at my work), however I’m still not seeing the Mycroft network during it’s set up. I haven’t tried the updated image yet. We’ll see if that works any better.


#30

I may be a little biased from some previous experiences attempting to run Raspian (GUI) along with Chromium. It was a little underpowered for that task, so I jumped to the ODROID C1/C2 platform for that project. The extra processing of the ODROID (1.5 Ghz quad core) made all the difference for that project.

Building a GUI-based Picroft image is on my TODO list. I just haven’t had time yet. So my doubts might be completely unfounded. Like I said, I’d be happy to be proven wrong!


#31

@Lucien_Storm

If your work has a “Click this button to access the web” portal page, then you won’t be able to use Picroft/Mycroft with that wifi today. We don’t have a mechanism that deals with those sorts of systems. But if you are looking for a good project we’d love help with solving that one!

Your option for today is to use a wired Ethernet connection, as long as that doesn’t have a portal page either.


#32

Hi the Pi image installs with an old core 08.03 i think. when it updates to kore 08.08 it breaks the pairing with home.mycroft.ai and you get an error.

At least its what i think is happening.