Mycroft on Ubuntu Mate not listening


#22

Thanks for the update will try to figure this out…


#23

An update on the previous issue with it not selecting the correct device. The device_name is a used as a regex match so the parenthesises are messing it up. It should work if you just enter HDA Intel MID: ALC270 Analog into your config.


#24

Have seen similar behaviour the last few days. For the mic meter to show on a fresh mycroft install, I need to start stop mycroft 3 times.

  1. Start mycroft, all default stuff get’s downloaded.
  2. Stop/Start mycroft, to be able to “set listener to precise”, however it downloads, yet never finishes nor switch to precise.
  3. Stop/Start mycroft, it eventually states the download is done. Not always switch to precise
  4. Stop/Start mycroft, precise is ready and used. Mic meter also shows real time switching

#25

@forslund: jep that fixed it, it’s picking the right mic now

@j1nx: tried that but doesn’t appear to be working, however when asked it says it’s using precise

Another new bug is that some output gets printed in the terminal instead of the tool, I think it’s when remote config gets fetched… After a few sec the tools removes it so no biggie:


#26

Unfortunately, this still isn’t tackled. After a few busy days at work I booted up the Mycroft machine, only to find that recording once again isn’t working - nothing showing up in pavucontrol. Tried rebooting, checked to see whether the settings were still in mycroft.conf - they’re there.

I pointed the listener to precise as you can read above here, but that never worked. I’ve set it back to pocketsphinx but no difference.

Weird thing in the voice.log is, it just stops in the middle as you can see here. Seems to be halting on something?

Do any of you have any idea of what’s so different about this system - it’s Ubuntu Mate 18.04 with a Blue Snowball mic. Vanilla install and dedicated laptop, nothing else has been done with it.


#27

That is interesting that the voice.log just completely stops. Can you post up your other logs so we can see what’s happening across the board?

I’ve never run Ubuntu Mate, but there’s no reason it shouldn’t work. If I had a snowball I’d give it a test run :frowning:


#28

Damn, just saw that Ubuntu Mate still supports PowerPC’s, that is impressive!

What are the rough specs of the machine you are using?


#29

Sure, here are the logs; audio.log, bus.log, enclosure.log and skills.log.

The laptop’s an HP G62, i3 M350 @ 2.27Ghz * 4, 3.7GB memory, 512GB SSD.

Yea Ubuntu Mate’s great, I prefer the interface over regular Ubuntu. But I guess I could just switch to regular if this isn’t going to work; a Mycroft machine that’s unable to run Mycroft loses all sense of purpose - and then we’ll have a bunch of Marvin-like Mycrofts :thinking: