Build an open future with us.

Invest in Mycroft and become a community partner.

Mycroft won't respond to my voice


#1

I keep saying hey Mycroft but it won’t respond I just finished the installation process


#2

Picroft? Git? Mk1?
Does the cli work if picroft/mk1?


#3

I’m having similar issues with my Mk1. It does respond eventually but it takes a couple tries. Not sure if it’s the microphone placement, ambient noise or maybe it’s just buggy.


#4

I don’t think the cli works either when I say hey mycroft he says sorry I didn’t catch that


#5

If it’s saying it didn’t catch that, that message usually indicates that it’s gotten the wake word, but can’t understand what came after the wake word. Can you check the log (picroft/mk1 in /var/log/mycroft-speech.log) and see if you can find anything of note, or tail -f the log while you try saying something to it.


#6

Im not sure how to check the log


#7

It doesn’t sound like this is the case for you, but someone else might have the same issue I did.

Mycroft wouldn’t respond to my voice, so I lowered my voice half a step and said, “hey, Mycroft”. I repeated this until my voice was about half an octave lower. Mycroft responds every time now, as long as I lower my voice sufficiently.

I’m going to try other alterations to my voice and see if changing the intonation makes a difference, or emphasis on a syllable, or the speed.

If anyone else experienced this and figured it out, I would be interested in hearing your workaround.