Naptime: handling wake up by text


#1

Hey all.

I was really unsure where to post this, and if it even belongs here rather than the skill’s GitHub page. It’s not an issue, though, so it seemed unfit for GitHub. It’s more like an inquiry for ideas, I suppose, but I couldn’t find a category for more generally related Skill talks. Anyway, let me know if I’m completely off-track here, and I’ll attempt to fix.

Here goes: I am having a few difficulties getting Mycroft to actually wake up again. I think it might be my pronouncing the wakeword very badly, or maybe the sensitivity is too low, I don’t know, but as it seems like I’m pretty much alone with this problem, I’m assuming it’s on my end, so I’ve been thinking about a workaround, and that would be the ability to handle it with a text command, possibly via the messagebus. But messing around with this and perusing the source code has left me with zero results whatsoever, so now I’m looking to you, fellow Mycroft-ians :slight_smile:

Hope you can help, and many thanks in advance!


#2

Hi kyppo,

This is a great place for ideas and feedback.

In terms of the issue you’ve been having, I’d be interested to know if there’s been any improvement following the new backend release this week?

Secondly, we do have some new tooling in the works that should significantly improve wake word spotting for those who’s voices aren’t being picked up well today. Hopefully we’ll have a firmer announcement on that soon, but just to let you know that it’s certainly something we are aware of and working to address. We know that women’s voices in particular haven’t been as prominent in the training data we’ve been able to collect and hence the resulting model reflects this bias.

In terms of other ways to wake Mycroft up, what sort of device are you using for Mycroft at the moment. The Mark 1 has the button on top and some people (like Chatterbox) have added buttons to their Picrofts to use as an additional waking option.
If you happen to be running KDE Neon, the Plasmoid has a trigger button.

For triggering it from the CLI, I’m wondering if a simple “Wake Skill” would be the easiest way to achieve what you’re suggesting. All it would need to do is have a simple intent trigger, then prompt the user for a response and pass this to the messagebus as an utterance.

Another alternative would be to connect to the messagebus directly and perhaps emit a recognizer_loop:wakeword message


#3

Thanks for the very elaborate answer! Things are a bit busy recently, but I will definitely get some thorough testing done when time permits, and then get back to you here. I think it might be likely that the recent updates may have brought improvements to my situation as well.

I am running Picroft on a Raspberry Pi 3 B+, with a Blue Snowball microphone. I have (of course) used Mycroft’s mic-test a couple of times, so I’m quite sure the hardware isn’t a problem.

I also did try the messagebus way, but maybe I didn’t utilize it correctly. If the backend updates don’t do the trick, I’ll look into the messagebus again, perseverance is key! My goal, should Mycroft still prove unwilling to cooperate with this, is to make a button on my homemade home control mobile app, that will let me wake up Mycroft easily.

Anyway, thanks again for your answer, it has certainly given me something to look at, which I will in the next few days, I hope :slight_smile:


#4

Currently the only way to resume after going to sleep is by voice. Even the top button won’t wake the device if I remember correctly. This is basically a security feature so no skill can inject a message causing listening to resume.

I do think it’s not a bad idea to make a “messagebus wakeup” an configurable option and is something we should do.

The “wake up” part of the “Hey Mycroft wake up” command is handled by pocket sphinx so it’s a bit less reliable than the Precise wakeword handler used for the “Hey Mycroft” part which can be troublesome. Especially on picroft since you don’t have any indication that the device started to listen for the Wake up at all…