Mycroft Community Forum

New installation no audio on Ubuntu 18.04

Hello there,

I cloned the github repo, ran the install script (without errors), and started mycroft via the bash script.

I can see it detecting my microphone input in the cli, but it seems to be doing no processing of it, there is no output of any kind (aside from the volume bar). Entering a command manually in the console gives a proper textual response. I also do not get any kind of audio output from mycroft at all, neither speech nor a ping noise. I tried some of the things suggested in similar threads to no avail, including restarting my machine, this Mycroft not responding to "pair my device" and manually setting audio sink via pactl.

Here is a dump of all my logs after restarting mycroft:

https://pastebin.com/0vjzMqkp

Looks like the audio can’t find mimic so no speech can be generated.

If you have paired, change the voice selected for your device to “American Male” on home.mycroft.ai (to right menu -> devices -> YOUR DEVICE -> edit)

if you haven’t paired you need to re-run dev-setup.sh and build mimic.

And if you don’t want to compile it I’ve built an inofficial debian package

curl https://forslund.github.io/mycroft-desktop-repo/mycroft-desktop.gpg.key \| apt-key add - 2> /dev/null && echo "deb http://forslund.github.io/mycroft-desktop-repo bionic main" > /etc/apt/sources.list.d/mycroft-desktop.list
apt-get update && apt-get install -y mimic

Yep that did it, thank you

1 Like