Next Steps on a Pi3 install


#1

HI!

After a few false starts I finally got the Pi3 up and running. There false starts are:

  1. You need a card bigger than 4GByte.
  2. The wifi has to be done manually as the the password MYCROFT1 does not work

Mycroft happily reported it was updating and was ready for the trigger word. As my USB microphone hasn’t arrived yet I tried to use the cli “say” command, and this is where I need help with the next steps of setting up the Pi3 versions. I have not found anywhere ( yet but still searching) on setting up mycroft. By this I mean the error message for the say command says it can’t find /home/pi/.mycroft/mycrofy.conf. This is true as there isn’t one. But where do I find out why and when I need one.

The second error on the say command is:

WARNING Failed to fetch remote configuration" HTTPError(u` the supplied authentication is invalid’,)

I assume the error is due to a lack of the mycroft.conf file in my home directory. If that’s true, can someone point me to setting this up. Do I clone the one from the mycroft directories?

Setup is PI3 8Gb card speaker connected to the audio out on the Pi. I tested the audio with the play command and it is working fine. Still waiting for UPS to deliver a microphone.

Thanks in advance

Dave


#2

So Mycroft starts automatically on the Pi3. If you’re running the cli, you should be able to interact. Try “what time is it” or “how tall is the eiffel tower”.


#3

Hi Karl,

Thanks for the reply.

I saw some info in the log of a response to the typed question, but no audio output.
Today the USB microphone arrived so I started to test with it.

I see in the log the the microphone is picking up the the sounds and working, But there is no audio output. I tried the test-microphone command and again no output. When Mycroft waked up to the trigger word there is a short bleep or tone that comes out of the speaker, but no spoken words. the tone sounds like it is an audio prompt from Mycroft. I tested the speaker with aplay again and it outputs just fine.

I also noticed that Mycroft updated today and blew away my wifi config and that caused a few errors, but was quickly fixed. So I’m now back to testing with a USB microphone on wifi and the error message I get after speaking a "Hey Mycroft. What time is it? is:

sr/local/bin/mimic: error while loading shared libraries: libttsmimic_lang_vid_gb_ap.so.0: cannot open shared object file: No such file or directory.

The mimic file is there. So will look through the forum and see if I can find what the issue is unless you know a quick answer.

Cheers

Dave


#4

I don’t know a quick answer, but it does sound like a problem with Mimic that I haven’t heard of. On the Picroft, it should already be built and working. If you’re getting audio but no voice, the issue is Mimic. Can you also try pasting some from your logs?

They’re in etc/log/ and try looking for mycroft-voice.log.


#5

Sorry for the delay in replying, but been away. Will fire up the Pi and look at the logs later today and post the results.


#6

there’s no logs in /etc/mycroft. But there are some in /var/log. Here is the tail of the log
/var/mycroft-speech-client.log

2017-06-26 14:38:09,923 - mycroft.messagebus.client.ws - INFO - Connected
2017-06-26 14:38:11,872 - mycroft.client.speech.mic - DEBUG - Waiting for wake word…
2017-06-26 14:38:55,141 - mycroft.configuration - INFO - Loading configuration: /usr/local/lib/python2.7/site-packages/mycroft_core-0.8.16-py2.7.egg/mycroft/configuration/mycroft.conf
2017-06-26 14:38:55,144 - mycroft.configuration - DEBUG - Configuration ‘/usr/local/lib/python2.7/site-packages/mycroft_core-0.8.16-py2.7.egg/mycroft/configuration/mycroft.conf’ loaded
2017-06-26 14:38:55,145 - mycroft.configuration - DEBUG - Configuration ‘/home/mycroft/.mycroft/mycroft.conf’ loaded
2017-06-26 14:38:55,145 - mycroft.configuration - INFO - Loading configuration: mycroft.ai
2017-06-26 14:38:55,151 - requests.packages.urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai
2017-06-26 14:38:55,238 - mycroft.client.speech.listener - DEBUG - Config has changed, reloading…
2017-06-26 14:38:56,224 - requests.packages.urllib3.connectionpool - DEBUG - https://api.mycroft.ai:443 “GET /v1/device/4444b745-e926-4495-972d-b3f1aeec9143/setting HTTP/1.1” 200 2921
2017-06-26 14:38:56,241 - requests.packages.urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai
2017-06-26 14:38:57,167 - requests.packages.urllib3.connectionpool - DEBUG - https://api.mycroft.ai:443 “GET /v1/device/4444b745-e926-4495-972d-b3f1aeec9143/location HTTP/1.1” 200 891
2017-06-26 14:38:57,187 - mycroft.configuration - INFO - Loading configuration: /etc/mycroft/mycroft.conf
2017-06-26 14:38:57,188 - mycroft.configuration - DEBUG - Configuration ‘/etc/mycroft/mycroft.conf’ loaded
2017-06-26 14:38:57,189 - mycroft.configuration - DEBUG - Configuration ‘/home/mycroft/.mycroft/mycroft.conf’ loaded
2017-06-26 14:38:57,190 - mycroft.configuration - INFO - Loading configuration: /home/mycroft/.mycroft/mycroft.conf
2017-06-26 14:38:57,190 - mycroft.configuration - DEBUG - Configuration ‘/home/mycroft/.mycroft/mycroft.conf’ loaded
2017-06-26 14:38:57,191 - mycroft.configuration - DEBUG - Configuration ‘/home/mycroft/.mycroft/mycroft.conf’ loaded
2017-06-26 14:38:57,483 - mycroft.client.speech.mic - DEBUG - Waiting for wake word…
2017-06-26 14:38:57,547 - mycroft.client.speech.listener - DEBUG - Config has changed, reloading…
2017-06-26 14:38:59,807 - mycroft.client.speech.mic - DEBUG - Waiting for wake word…
2017-06-26 14:40:49,925 - mycroft.client.speech.mic - DEBUG - Recording…
2017-06-26 14:40:49,926 - SpeechClient - INFO - Begin Recording…
Playing WAVE ‘/usr/local/lib/python2.7/site-packages/mycroft_core-0.8.16-py2.7.egg/mycroft/res/snd/start_listening.wav’ : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
2017-06-26 14:40:51,175 - SpeechClient - INFO - End Recording…
2017-06-26 14:40:51,176 - mycroft.client.speech.mic - DEBUG - Thinking…
2017-06-26 14:40:51,178 - mycroft.session - INFO - New Session Start: 8f955cad-169e-4a16-9f16-6c8a877812e0
2017-06-26 14:40:51,179 - SpeechClient - INFO - Wakeword Detected: hey mycroft
2017-06-26 14:40:51,242 - requests.packages.urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai
2017-06-26 14:40:52,083 - requests.packages.urllib3.connectionpool - DEBUG - https://api.mycroft.ai:443 “POST /v1/stt?lang=en-US&limit=1 HTTP/1.1” 200 None
2017-06-26 14:40:52,140 - mycroft.client.speech.mic - DEBUG - Waiting for wake word…
2017-06-26 14:40:53,017 - mycroft.client.speech.listener - DEBUG - STT: what time is it
2017-06-26 14:40:53,018 - SpeechClient - INFO - Utterance: [u’what time is it’]
ignoring unknown attr section aeacK
invalid section len 51839253, max remaining 16
ignoring unknown attr section

sr/local/bin/mimic: error while loading shared libraries: libttsmimic_lang_vid_gb_ap.so.0: cannot open shared object file: No such file or directory
2017-06-26 14:40:53,086 - SpeechClient - INFO - Speak: Currently 02:40, PM
ignoring unknown attr section aeacK
invalid section len 51839253, max remaining 16
ignoring unknown attr section

sr/local/bin/mimic: error while loading shared libraries: libttsmimic_lang_vid_gb_ap.so.0: cannot open shared object file: No such file or directory.

Does that help?


#7

Here’s a link to a lot of info on the Pi setup if that helps:

https://pastebin.com/Q8aBmwGv

Cheers

Dave


#8

It would be nice to have some kind of reaction here.
I have the exact same issues with my RPi3.

Additional Info:

  • During the first launch, Mycroft reacted at the point where you are on the homepage and it asks you to try the test sentences.
  • After reboot he says: " Sorry, I didn’t catch that" which is the last you hear from him
  • I tried the Audio Errors solutions https://docs.mycroft.ai/installing.and.running/faq/audio.issues which did not help. pulseaudio -D gives me: E: [pulseaudio] main.c: Daemon startup failed. Changing alsa.conf to card 1 (gained from cat /proc/asound/cards) since it was set to 0 did not help. cat /proc/asound/card1/pcm0c/info is correctly set to 1

I reflashed picroft afterwards. Same behavior.

cat /proc/asound/cards:

0 [ALSA ]: bcm2835 - bcm2835 ALSA bcm2835 ALSA
1 [Device ]: USB-Audio - USB PnP Sound Device C-Media Electronics Inc. USB PnP Sound Device at usb-3f980000.usb-1.2, full spe


#9

I also seem to hit another stage today:

W: GPG error: http://repo.mycroft.ai debian InRelease: The following signatures were invalid: KEYEXPIRED 1498079146 KEYEXPIRED 1498079146 KEYEXPIRED 1498079146 KEYEXPIRED 1498079146

This was in response to
sudo apt-get update

One other hiccup to note on my Pi3. Wifi fails to come up on boot. I have to connect to a hardwired connection first. This Pi3 ran for over 10 months on wifi on another project so I suspect software. The error indicates it’s trying to get an IPv6 address. I don’t have that turned on in my network. But it was never a problem before or any other of the Pi’s I have running various projects around the house.

Perhaps this package/version is not ready to deploy on Pi at this time.


#10

Running sudo apt-get update on my Mark_1 I get the same response:
W: GPG error: http://repo.mycroft.ai debian InRelease: The following signatures were invalid: KEYEXPIRED 1498079146 KEYEXPIRED 1498079146 KEYEXPIRED 1498079146 KEYEXPIRED 1498079146

What does this mean? How do I update the keys?

Thanks,
Dean


#11

Hello, the KEYEXPIRED error can be fixed by running the following command:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys F3B1AA8B

Let me know if this helps! :slight_smile:

  • Matthew

#12

Hi Matthew,
Thanks that fixed that issue and I did get an update. But still have same error with mimic. So Mycroft does speak. He does listen quite well😉


#13

Does not speak I meant!


#14

Also now being tracked on github: