No speech output


#1

I’m brand new to Mycroft and installed it using the Github instructions on a Ubuntu guest on an OS X host using VirtualBox. When using it with CLI I can see that Mycroft hears my speech and responds appropriately with text output, but there is no speech output. I know the speakers are working (I can hear the ding of Mycroft responding to the wake word). Tails for the voice and audio logs are at https://pastebin.com/z2sLdB2X. Any assistance would be greatly appreciated. Thanks!


#2

@Raj1 do you have mimic built? to check go to the Mycroft-core/mimic directory. There you can do ./mimic -t "hello world". You should then hear mycroft say “hello world”. If not then you most likely do not have mimic built. You can run ./dev-setup in the mycroft-core root directory again to build it.

Hope that helps
-Michael


#3

That solved it, thank you!


#4

I have similar problem (docker on Linux). Voice is recognized, ding is heard, yet I see answers only in “start-mycroft.sh debug” window, no speech output.
mimic works properly. This happened after I tried to switch to google synthesizer and then back.
“stt”: { “module”: “mycroft” },
“tts”: { “module”: “mimic”,
“mimic”: {
“voice”: “ap”
},
“mimic2”: {
“lang”: “en-us”,
“url”: “https://mimic-api.mycroft.ai/synthesize?text=
},
“espeak”: {
“lang”: “english-us”,
“voice”: “m1”
}
},

I suspect REMOTE is set wrongly and overrides correct settings in the conf file. How can I see value of REMOTE config?


#5

My mistake, sorry - Mycroft home still had google tts specified. Changed it to mimic, had to restart mycroft and now it speaks!