Build an open future with us.

Invest in Mycroft and become a community partner.

Opions for device type not avaliable -> registers desktop as Mark1


#1

It seems like the device type option is no longer available,
as it registers my Ubuntu Desktop as Mark1.
So I’m not able to tell Mycroft to open Firefox etc.

Am I doing something wrong here?


#2

I’m seeing the same thing here as well, as seen in the above image.

My colleague @matheus-mycroft may have some more thoughts here?


#3

Hi @martnnw - can you confirm if you used a GitHub-based install for your Ubuntu Desktop? Are you able to tell me which version of Ubuntu you’re using?
Thanks, Kathy


#4

I followed the instructions on your page, by entering the following commands:

cd ~/
git clone https://github.com/MycroftAI/mycroft-core.git
cd mycroft-core
bash dev_setup.sh

I tried switching to the master branch but it was still the same URL.
It also fails to recognize by cloning: --depth=1 https://github.com/MycroftAI/mycroft-core.git

I’ve also tried it with Raspbian: same problem

Screenshot%20from%202018-08-07%2010-27-10


#5

Useful debugging info, thanks!


#6

Hi @martnnw, my colleague @matheus-mycroft had a look at this one for you. We believe you may need this Skill


which avoids the dependency on the gi package.

However, it’s not in the mycroft-skills repo so you would need to manually install it. Are you comfortable doing that?

Kind regards,
Kathy


#7

Thanks! I’ve been searching for that skill for a while now!
And yes I’m comfortable doing that :slight_smile:


#8

Awesome! Let us know how you go!