Pandora Playback issues


#1

Hmmmmm…I have an issue that I think I know what it is, but not sure how to fix it. When I say “Hey Mycroft, play Pandora”, Pandora starts playing, but at super slow speed. The news plays well, but it uses a different playback method. The voice works well, but not with long utterances. The biggest thing is Pandora. I use it often and would love to have it fixed.


#2

I agree. Mine stops after a few songs. @steve.penrod - when will this be fixed?


#3

Hey builderjer,

From memory you have a few devices running Mycroft is that right? Is the slow playback occurring across all devices or just one?

It sounds like this is a different issue to the playback stopping after a few songs. Last time it happened, I believe there was an issue with the pianobar package that we use, but I will take a look and see what we can find.


#4

This one is on a fresh picroft.


#5

I found this old pianobar issue that describes a similar issue.

The first (easiest) thing I’d try is reducing the audio quality. You can do this by editing your pianobar config which should be located at:
~/.config/pianobar/config
and add/edit the following line
audio_quality = low

Second, for at least some people it was an issue with libao. The fix there was to edit:
/etc/libao.conf
and change:
default_driver=alsa
to read
default_driver=pulse

If neither of those work I’d also be interested to see what your CPU load and memory usage look like at rest vs when Pandora is playing. I’m assuming this is a Raspberry Pi 3?


#6

Yes, it’s a pi 3, I will try your suggestions when I get a chance. Thanks for your research.


#7

Neither of these options worked for me. How do I show CPU usage while running Mycroft?


#8

htop should be installed. So if you open another ssh shell and hit ctrl+c to exit the CLI.

You can just run:
htop

This provides a nice terminal GUI to view the running processes and system resource usage.


#9

I figured that out, and was getting ready to post here. It normally goes, with all 4 processors, between 48 and 58%. No matter if I’m playing Pandora, or not. I will try it on my other machine, not pycroft, and see what happens


#10

Can you try running pianobar without Mycroft and see if it’s the same?

Exit the CLI and run pianobar

It should have your login credentials configured already so will give you a list of stations, just use the station number to select.


#11

Same thing!! Arghhh!!


#12

Tested on another machine and it works fine. Must be a pi error


#13

As in same thing just using pianobar?


#14

Yes, sloooooowwwww playback. Works fine on my other machine. Just not my pi. It sounds very robotic and jittery. Is there a way I can post an audio file so you can hear?


#15

You can record from the mic and save it to a file with:
arecord -d 10 -o test.wav
d = duration in seconds - ie 10 seconds here

I’ve done a callout in the Picroft Chat channel to see how widespread this is too.