Mycroft Community Forum

Pandora skill asks for registration

the pandora skill keeps sking me to go to home.mycroft.ai to register it ,but their is no registration info on that page .

witch is my account page?

what do I need to do?

this is on the desktop plasmoid

VINNY

Hello @vinnywright,
Is it the Pandora skill specifically or your mycroft-core instance that is asking for registration?

Hey, I have the same problem. How would you tell which is asking for the registration? The direct quote from the log is "(Date, Time - SpeechClient - INFO - Speak : Please go to home.mycroft.ai to register pandora"
Picture of log
(If the picture doesn’t work, just tell me.)

it’s asking to register pandora ,so I would say Pandora , but I have a pandora acct .

VINNY

So I think @steve.penrod 's team is working on this. The new Pandora skill was supposed to allow users to manage their permissions in the cloud ( the original required you to add them via the CLI ). This was part of the large update we did last week that went…awry…when implemented.

I expect that this will be working some time in the near future when they get the kinks out of the update and get the 17.08a release out the door.

What you can do for now instead rely on going to home.mycroft.ai, since that is still in the works, is to input your pandora account info though the terminal.

Following the steps in the README should set this up

@Mn0491 I have done already all in the README ,nope

@J_Montgomery_Mycroft I will wate for an update then :wink:

VINNY

@vinnywright I apologize. Can you try it now? I’ve realized that the master branch had the file settingsmeta.json which is meant for the new web settings update mentioned. That file causes mycroft to do an api request to the backend to input your pandora credentials at home.mycroft.ai, but that update is not out yet. I’ve updated the master branch by deleting the file. You can either re-clone and redo the steps, or try deleting the settingsmeta.json file. I just tried a fresh install on picroft and it seems to be working for me.

hope this solves it!

@Mn0491 sorry I have been busy,all smiles now it’s working just fine after removing the settingsmeta.json from /opt/mycroft/skills/pianobar-skill/

I started to remove it myself when I created the settings.json , but thought ,no,maybe it’s needed …LOL

it seemed to cause a lot of trouble as after a few mins of playing around sherlock’s brother ,O Mycroft would ask for me to register him several times in a row with multiple codes ,but that could be a prob of another skill ,if it reappears I will try to narrow it down .

VINNY

Hi All, I know this is an old thread but I’m experiencing this issue on my PiCroft after running updates and rebooting. I’ve attempted removing the skill and reinstalling, and following the last response suggestion and removing the settingsmeta.json file (now located in the mycroft-pandora directory). I cant get PiCroft to play pandora - it keeps telling me to set it up in mycroft.ai (done several times) :frowning:

Any help/suggestions?

Thanks!
Tdubz