Mycroft Community Forum

Pandora voice control issue

I can get PiCroft to play Pandora, but it then not respond to voice commands. If I ssh in, it responds to typed commands fine. Any suggestions? Thanks.

I believe this is what you are after;

Hi
I get this error when I make the changes suggested in /home/pi/mycroft-core/mycroft/configuration/mycroft.conf
Please advise, thanks.

Starting background service skills
Starting cli
2020-04-08 21:52:51.246 | ERROR | 718 | mycroft.configuration.config:load_local:112 | Error loading configuration ‘/home/pi/mycroft-core/mycroft/configuration/mycroft.conf’
2020-04-08 21:52:51.510 | ERROR | 718 | mycroft.configuration.config:load_local:113 | JSONDecodeError(‘Expecting property name enclosed in double quotes: line 1 column 2069 (char 2068)’)
2020-04-08 21:52:51.778 | ERROR | 718 | mycroft.configuration.config:load_local:112 | Error loading configuration ‘/home/pi/mycroft-core/mycroft/configuration/mycroft.conf’
2020-04-08 21:52:52.042 | ERROR | 718 | mycroft.configuration.config:load_local:113 | JSONDecodeError(‘Expecting property name enclosed in double quotes: line 1 column 2069 (char 2068)’)
Traceback (most recent call last):
File “/usr/lib/python3.7/runpy.py”, line 193, in _run_module_as_main
main”, mod_spec)
File “/usr/lib/python3.7/runpy.py”, line 85, in _run_code
exec(code, run_globals)
File “/home/pi/mycroft-core/mycroft/client/text/main.py”, line 21, in
from .text_client import (
File “/home/pi/mycroft-core/mycroft/client/text/text_client.py”, line 21, in
from mycroft.tts import TTS
File “/home/pi/mycroft-core/mycroft/tts/init.py”, line 20, in
from .tts import TTSFactory, TTS, TTSValidator, PlaybackThread
File “/home/pi/mycroft-core/mycroft/tts/tts.py”, line 453, in
class TTSFactory:
File “/home/pi/mycroft-core/mycroft/tts/tts.py”, line 458, in TTSFactory
from mycroft.tts.mimic_tts import Mimic
File “/home/pi/mycroft-core/mycroft/tts/mimic_tts.py”, line 32, in
config = Configuration.get().get(“tts”).get(“mimic”)
File “/home/pi/mycroft-core/mycroft/configuration/config.py”, line 195, in get
return Configuration.load_config_stack(configs, cache)
File “/home/pi/mycroft-core/mycroft/configuration/config.py”, line 209, in load_config_stack
configs = [LocalConf(DEFAULT_CONFIG), RemoteConf(),
File “/home/pi/mycroft-core/mycroft/configuration/config.py”, line 140, in init
if not is_paired():
File “/home/pi/mycroft-core/mycroft/api/init.py”, line 506, in is_paired
api = DeviceApi()
File “/home/pi/mycroft-core/mycroft/api/init.py”, line 227, in init
super(DeviceApi, self).init(“device”)
File “/home/pi/mycroft-core/mycroft/api/init.py”, line 59, in init
self.url = config_server.get(“url”)
AttributeError: ‘NoneType’ object has no attribute ‘get’