Build an open future with us.

Invest in Mycroft and become a community partner.

Pi croft audio play back problem


#1

Hi Mycroft

Please excuse the second post on this, maybe my first question wasn’t clear.

I have Picroft with raspeberry pi 3 and a ReSpeaker 2Mics pHAT.

I get this message when it boots up. “Couldn’t allocate mixer Alsaaudio error (unable to find mixer control master 0)”

Mic and speaker work when tested with ‘arecord -d 10 test. wav’ and ‘aplay test.wav’

Mycrfoft hears me and does his speech to text thing, but I get nothing form the speaker. If I plug headphones into the audio jack on the Pi I do get some sound (and very faint sound if speaker is connected).

Thanks for reading

Aaron


#2

Please try to select your playback device using alsamixer command.


#3

Thanks for you reply
I have tried that, buy it does not seem to work I am not to able to save the setting. I think it just goes back to the default when I press esc to exit.
Cheers
Aaron


#4

Thanks for the useful information @aaron57.
I also had a person who had a similar issue a couple of days ago.
All that I can think of is that alsamixer is not saving settings properly.

I read this article on the Ubuntu forums about saving settings in alsamixer using elevated privileges. I don’t suppose you want to give that a try and see if it works?


#5

Hi Kathy

Thanks for your replies

I have tried a couple of the solutions in the post, but I still can’t get alsa to save the settings even with ‘sudo alsamixer’.

My linux skills are not good enough to try the more complex solutions, I am not sure how to navigate to the files and do the necessary edits.

I do not know what to do to get this mycroft growling, Should I try to reload the whole operating system, or can somebody talk me through editing the alsa configuration?

Cheers
Aaron


#6

Have you tried asking “set volume to 100 percent”? Others gave had issues were volume was set too low.


#7

I think I have covered that. I go to the alsa mixer gui, turn everything right up and hit esc to log out. I boot up mycroft and I still have no sound and when I go back to the alsa gui all the settings are the same as before I changed them. I think this is a coding issue, the gui does not seem to work.
Thanks
Aaron


#8

Hey Mycroft
Is it possible to flash a version of raspbian onto my Raspberry pi and then install Mycroft on top? I am familiar with linux window managers so I might have a better chance of sorting out the sound problem.
Cheers
Aaron


#9

Hey @aaron57 yes this is possible - you want the Picroft image recipe at;