Picroft 20.8.0 3B+ and raspiaudio HAT mic not working test OK

Hi all,

I have just set up a Picroft runnin on a RaspberryPi 3B+ and added the Raspiaudio MIC+ HAT.

During the setup wizard I had to select the Google AIY option as I couldn’t skip this item, then I installed the HAT drivers as per the manufacturer.

Re-ran the setup wizard and audio and mic test are good.

However, when the mycroft-cli-client starts, microphone level bar does not move and there are no audio logs.

I have run audiotest successfully with the playback audio coming out low in volume.

If I type a command the audio output has good volume.

(.venv) pi@picroft:~ $ mycroft-start audiotest -l
Already up to date.
Initializing…
Starting audiotest
Initializing…
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.front
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround21
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround21
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround40
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround41
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround50
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround51
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround71
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.iec958
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.iec958
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.iec958
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.modem
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.modem
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline
ALSA lib pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
ALSA lib pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
ALSA lib pcm_a52.c:823:(_snd_pcm_a52_open) a52 is only for playback
ALSA lib conf.c:5014:(snd_config_expand) Unknown parameters {AES0 0x6 AES1 0x82 AES2 0x0 AES3 0x2 CARD 0}
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM iec958:{AES0 0x6 AES1 0x82 AES2 0x0 AES3 0x2 CARD 0}
ALSA lib pcm_usb_stream.c:486:(_snd_pcm_usb_stream_open) Invalid type for card
ALSA lib pcm_usb_stream.c:486:(_snd_pcm_usb_stream_open) Invalid type for card
ALSA lib pcm_dmix.c:1043:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
ALSA lib pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm_dsnoop.c:638:(snd_pcm_dsnoop_open) unable to open slave
ALSA lib pcm_dsnoop.c:575:(snd_pcm_dsnoop_open) The dsnoop plugin supports only capture stream
ALSA lib pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave
====================== Audio Devices ======================
Index Device Name
0: pulse
1: default

========================== Info ===========================
Input device: default @ Sample rate: 8000 Hz
Playback commandline: aplay WAV_FILE

===========================================================
== STARTING TO RECORD, MAKE SOME NOISE! ==

===========================================================
== DONE RECORDING, PLAYING BACK… ==

Playing WAVE ‘/tmp/test.wav’ : Signed 16 bit Little Endian, Rate 16000 Hz, Mono

I have set the config file to:

{
“play_wav_cmdline”: “aplay %1”,
“play_mp3_cmdline”: “mpg123 %1”,
“enclosure”: {
“platform”: “picroft”
},
“tts”: {
“mimic”: {
“path”: “/home/pi/mycroft-core/mimic/bin/mimic”
}
},
“ipc_path”: “/ramdisk/mycroft/ipc/”
}

Here’s the output of Pulse commands

(.venv) pi@picroft:~ $ pactl info
Server String: /run/user/1000/pulse/native
Library Protocol Version: 32
Server Protocol Version: 32
Is Local: yes
Client Index: 40
Tile Size: 65496
User Name: pi
Host Name: picroft
Server Name: pulseaudio
Server Version: 12.2
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.platform-soc_sound.stereo-fallback
Default Source: alsa_input.platform-soc_sound.stereo-fallback
Cookie: 08be:ceed

(.venv) pi@picroft:~ $ pactl list sinks short
0 alsa_output.platform-soc_sound.stereo-fallback module-alsa-card.c s32le 2ch 48000Hz IDLE

(.venv) pi@picroft:~ $ pactl list sources short
0 alsa_output.platform-soc_sound.stereo-fallback.monitor module-alsa-card.c s32le 2ch 48000Hz IDLE
1 alsa_input.platform-soc_sound.stereo-fallback module-alsa-card.c s32le 2ch 48000Hz IDLE

(.venv) pi@picroft:~ $ pactl list modules short
0 module-device-restore
1 module-stream-restore
2 module-card-restore
3 module-augment-properties
4 module-switch-on-port-available
5 module-udev-detect
6 module-alsa-card device_id=“0” name=“platform-soc_sound” card_name=“alsa_card.platform-soc_sound” namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes card_properties=“module-udev-detect.discovered=1”
7 module-native-protocol-unix
8 module-default-device-restore
9 module-rescue-streams
10 module-always-sink
11 module-intended-roles
12 module-console-kit
13 module-systemd-login
14 module-position-event-sounds
15 module-role-cork
16 module-filter-heuristics
17 module-filter-apply

(.venv) pi@picroft:~ $ sudo apt-get install pulseaudio
Reading package lists… Done
Building dependency tree
Reading state information… Done
pulseaudio is already the newest version (12.2-4+deb10u1+rpi3).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Thanks in advance!

Also, I took a look at

I checked my /lib/udev/rules.d/91-pulseaudio-rpi.rules and it’s as it should be:

(.venv) pi@picroft:~ $ cat /lib/udev/rules.d/91-pulseaudio-rpi.rules
SUBSYSTEM!=“sound*”, GOTO=“end”
ACTION!=“change”, GOTO=“end”
KERNEL!=“card*”, GOTO=“end”
ENV{SOUND_FORM_FACTOR}!=“internal”, GOTO=“end”

DRIVERS==“bcm2835_audio”, ATTR{id}==“b1”, ENV{PULSE_PROFILE_SET}=“rpi-hdmi.conf”, GOTO=“end”
DRIVERS==“bcm2835_audio”, ATTR{id}==“b2”, ENV{PULSE_PROFILE_SET}=“rpi-hdmi.conf”, GOTO=“end”
DRIVERS==“bcm2835_audio”, ATTR{id}==“Headphones”, ENV{PULSE_PROFILE_SET}=“rpi-analog.conf”, GOTO=“end”

LABEL=“end”

I see one of the troubleshooting steps suggesting switching Sphinx to Precise, but I don’t know if this is relevant as it doesn’t seem the CLI is detecting any audio input.

Quick question: do you have an HDMI monitor connected? I’ve had nothing but problems getting the sound output to work when a monitor is set up. I always connect through SSH anymore.

A quick check I use is to run ALSAMIXER. When everything is working for me, Pulseaudio is the default output. Make certain that the volume levels are good. Then I just verify the default Pulseaudio source and sink.

I have finally gotten the audio issues smoothed out in my animatronics. I use a homemade audio bonnet with an I2S amp and an I2S microphone connection.

Hi @Charles,

I’m using the 7" touch display connected directly to the RPi. The only audio connected to my setup is the Raspiaudio MIC+ HAT which comes with a mic and two speakers.

Default output is Pulseaudio, I have no issues hearing responses from Mycroft if I type the command.

All tests suggested at the Mycroft Audio Troubleshooting page are successful (see https://mycroft-ai.gitbook.io/docs/using-mycroft-ai/troubleshooting/audio-troubleshooting#other-useful-commands), but when starting mycroft-cli-client the mic indicator shows no activity and I see no logs for the listener.

From Alsamixer:



mycrogt-cli-client, typing command works and audio response from mycroft is heard, no voice detection.

Great info. So, just to make certain that I understand, the microphone works during the setup and testing, but not within Mycroft. If that is the case, then the hardware is good and the basic drivers are properly installed. That just leaves the Pulseaudio-to-Mycroft connection.

Can you check the default Pulseaudio source? Just to make certain that Pulseaudio is using your microphone and not some secondary microphone, like an ambient noise sensor.

Stop and start Mycroft. Don’t reboot, just shutdown the AI and then bring it back up.

Oh, and here is the page for the mic install. My guess is that you already found this: https://forum.raspiaudio.com/t/mic-installation-guide/17

According to pactl info it should be OK

(.venv) pi@picroft:~ $ pactl info
Server String: /run/user/1000/pulse/native
Library Protocol Version: 32
Server Protocol Version: 32
Is Local: yes
Client Index: 40
Tile Size: 65496
User Name: pi
Host Name: picroft
Server Name: pulseaudio
Server Version: 12.2
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.platform-soc_sound.stereo-fallback
Default Source: alsa_input.platform-soc_sound.stereo-fallback
Cookie: 92ac:228c

I have not edited any pulseaudio config files:

(.venv) pi@picroft:~ $ cat /etc/pulse/client.conf | grep default
; default-sink =
; default-source =
; default-server =
; default-dbus-server =
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB

(.venv) pi@picroft:~ $ cat /etc/pulse/default.pa | grep default
### Automatically restore the default sink/source when changed by the user
### that look up the default sink/source get the right value
load-module module-default-device-restore
### Automatically move streams to the default sink if the sink they are
### Make some devices default
#set-default-sink output
#set-default-source input

I tried this but didn’ t change the behavior:

(.venv) pi@picroft:~ $ pactl list sources short
0 alsa_output.platform-soc_sound.stereo-fallback.monitor module-alsa-card.c s32le 2ch 48000Hz IDLE
1 alsa_input.platform-soc_sound.stereo-fallback module-alsa-card.c s32le 2ch 48000Hz IDLE
(.venv) pi@picroft:~ $ pactl set-default-source 1
(.venv) pi@picroft:~ $ mycroft-stop
Stopping all mycroft-core services
Stopping skills (678)…stopped.
Stopping audio (681)…stopped.
Stopping enclosure (687)…stopped.
Stopping messagebus.service (675)…stopped.
(.venv) pi@picroft:~ $ mycroft-start
remote: Enumerating objects: 20, done.
remote: Counting objects: 100% (20/20), done.
remote: Compressing objects: 100% (10/10), done.
remote: Total 20 (delta 10), reused 16 (delta 6), pack-reused 0
Unpacking objects: 100% (20/20), done.
From https://github.com/MycroftAI/mycroft-core
8d13afc4e7…9212211614 test-github-actions -> origin/test-github-actions
Already up to date.
mycroft-start: Mycroft command/service launcher
<…>
<…>
(.venv) pi@picroft:~ $ mycroft-start all
Already up to date.
Starting all mycroft-core services
Initializing…
Starting background service bus
CAUTION: The Mycroft bus is an open websocket with no built-in security
measures. You are responsible for protecting the local port
8181 with a firewall as appropriate.
Starting background service skills
Starting background service audio
Starting background service voice
Starting background service enclosure

I’m at work right now. I’ll check my Pulseaudio settings when I get home tonight.

Thanks for checking, I did use the scripts to install the raspiaudio MIC+ after running the mycroft-setup-wizard.

I figured as much. You know what you’re doing. The Mycroft audio setup is a problem for everyone. Most of those audio tests don’t really test the Pulseaudio setup, which is what Mycroft seems to use. If you can get Pulseaudio set up properly with all the right defaults, then Mycroft is happy.

Run “pacmd list-sources”. It gives more useful information. Your “index: 1” device should have an asterisk.
(.venv) pi@winston:~ $ pacmd list-sources
2 source(s) available.
index: 0
name: <alsa_output.platform-soc_sound.stereo-fallback.monitor>
driver: <module-alsa-card.c>
flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
state: IDLE
suspend cause: (none)
priority: 1000
volume: front-left: 65536 / 100% / 0.00 dB, front-right: 65536 / 100% / 0.00 dB
balance 0.00
base volume: 65536 / 100% / 0.00 dB
volume steps: 65537
muted: no
current latency: 0.00 ms
max rewind: 512 KiB
sample spec: s32le 2ch 48000Hz
channel map: front-left,front-right
Stereo
used by: 0
linked by: 0
configured latency: 1365.33 ms; range is 0.50 … 1365.33 ms
monitor_of: 0
card: 0 <alsa_card.platform-soc_sound>
module: 6
properties:
device.description = “Monitor of Built-in Audio Stereo”
device.class = “monitor”
alsa.card = “0”
alsa.card_name = “snd_rpi_googlevoicehat_soundcar”
alsa.long_card_name = “snd_rpi_googlevoicehat_soundcard”
alsa.driver_name = “snd_soc_rpi_simple_soundcard”
device.bus_path = “platform-soc:sound”
sysfs.path = “/devices/platform/soc/soc:sound/sound/card0”
device.form_factor = “internal”
device.string = “0”
module-udev-detect.discovered = “1”
device.icon_name = “audio-card”

  • index: 1
    name: <alsa_input.platform-soc_sound.stereo-fallback>
    driver: <module-alsa-card.c>
    flags: HARDWARE DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
    state: IDLE
    suspend cause: (none)
    priority: 9000
    volume: front-left: 65536 / 100% / 0.00 dB, front-right: 65536 / 100% / 0.00 dB
    balance 0.00
    base volume: 65536 / 100% / 0.00 dB
    volume steps: 65537
    muted: no
    current latency: 412.09 ms
    max rewind: 0 KiB
    sample spec: s32le 2ch 48000Hz
    channel map: front-left,front-right
    Stereo
    used by: 0
    linked by: 0
    configured latency: 1365.33 ms; range is 0.50 … 1365.33 ms
    card: 0 <alsa_card.platform-soc_sound>
    module: 6
    properties:
    alsa.resolution_bits = “32”
    device.api = “alsa”
    device.class = “sound”
    alsa.class = “generic”
    alsa.subclass = “generic-mix”
    alsa.name = “Google voiceHAT SoundCard HiFi voicehat-codec-0”
    alsa.id = “Google voiceHAT SoundCard HiFi voicehat-codec-0”
    alsa.subdevice = “0”
    alsa.subdevice_name = “subdevice #0
    alsa.device = “0”
    alsa.card = “0”
    alsa.card_name = “snd_rpi_googlevoicehat_soundcar”
    alsa.long_card_name = “snd_rpi_googlevoicehat_soundcard”
    alsa.driver_name = “snd_soc_rpi_simple_soundcard”
    device.bus_path = “platform-soc:sound”
    sysfs.path = “/devices/platform/soc/soc:sound/sound/card0”
    device.form_factor = “internal”
    device.string = “hw:0”
    device.buffering.buffer_size = “524288”
    device.buffering.fragment_size = “262144”
    device.access_mode = “mmap+timer”
    device.profile.name = “stereo-fallback”
    device.profile.description = “Stereo”
    device.description = “Built-in Audio Stereo”
    module-udev-detect.discovered = “1”
    device.icon_name = “audio-card”
    ports:
    analog-input: Analog Input (priority 10000, latency offset 0 usec, available: unknown)
    properties:

    active port: <analog-input>

Here’s the output of the command, there is an asterisk on 1:

(.venv) pi@picroft:~ $ pacmd list-sources
2 source(s) available.
    index: 0
	name: <alsa_output.platform-soc_sound.stereo-fallback.monitor>
	driver: <module-alsa-card.c>
	flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: IDLE
	suspend cause: (none)
	priority: 1000
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.00 ms
	max rewind: 512 KiB
	sample spec: s32le 2ch 48000Hz
	channel map: front-left,front-right
	             Stereo
	used by: 0
	linked by: 0
	configured latency: 1365.33 ms; range is 0.50 .. 1365.33 ms
	monitor_of: 0
	card: 0 <alsa_card.platform-soc_sound>
	module: 6
	properties:
		device.description = "Monitor of Built-in Audio Stereo"
		device.class = "monitor"
		alsa.card = "0"
		alsa.card_name = "snd_rpi_googlevoicehat_soundcar"
		alsa.long_card_name = "snd_rpi_googlevoicehat_soundcard"
		alsa.driver_name = "snd_soc_rpi_simple_soundcard"
		device.bus_path = "platform-soc:sound"
		sysfs.path = "/devices/platform/soc/soc:sound/sound/card0"
		device.form_factor = "internal"
		device.string = "0"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card"
  * index: 1
	name: <alsa_input.platform-soc_sound.stereo-fallback>
	driver: <module-alsa-card.c>
	flags: HARDWARE DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: IDLE
	suspend cause: (none)
	priority: 9000
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 358.98 ms
	max rewind: 0 KiB
	sample spec: s32le 2ch 48000Hz
	channel map: front-left,front-right
	             Stereo
	used by: 0
	linked by: 0
	configured latency: 1365.33 ms; range is 0.50 .. 1365.33 ms
	card: 0 <alsa_card.platform-soc_sound>
	module: 6
	properties:
		alsa.resolution_bits = "32"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "Google voiceHAT SoundCard HiFi voicehat-codec-0"
		alsa.id = "Google voiceHAT SoundCard HiFi voicehat-codec-0"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "0"
		alsa.card_name = "snd_rpi_googlevoicehat_soundcar"
		alsa.long_card_name = "snd_rpi_googlevoicehat_soundcard"
		alsa.driver_name = "snd_soc_rpi_simple_soundcard"
		device.bus_path = "platform-soc:sound"
		sysfs.path = "/devices/platform/soc/soc:sound/sound/card0"
		device.form_factor = "internal"
		device.string = "hw:0"
		device.buffering.buffer_size = "524288"
		device.buffering.fragment_size = "262144"
		device.access_mode = "mmap+timer"
		device.profile.name = "stereo-fallback"
		device.profile.description = "Stereo"
		device.description = "Built-in Audio Stereo"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card"
	ports:
		analog-input: Analog Input (priority 10000, latency offset 0 usec, available: unknown)
			properties:
				
	active port: <analog-input>

Be aware that pacmd uses pulseaudio as user instance and reading from default.pa, while pactl uses pulseaudio as system service and reading from system.pa

If you start mycroft as service, start pulseaudio as service as well and use system.pa and pactl commands

if you start mycroft as user session from your .bash_profile as example, start pusleaudio as user session and use default.pa and pacmd commands.

Don’t mix and match stuff, because that is the most common reason of all sound troubles.

Also when you use pulse audio use commands susch as paplay. Using alsa, then use commands as aplay within your mycroft.conf

Hi @j1nx,

I’m using a picroft image, which I assume runs both mycroft and pulseaudio as a service.

All tests suggested by the Mycroft audio tshoot page are using pactl, aplay and mycroft-start audiotest, all test are successful but still Mycroft does not respond to voice commands, and there are no logs of any wake words detected along with the Mic indicator not moving.

Is there any other information you would like me to collect from my setup?

Thanks,

Picroft really has not received the love it needs the last year. The used sound architecture within picroft started by utilizing alsa, however migrated over later on to pulseaudio. Also kind of forced by the underlying raspbian that is used as based.

So in the current state picroft is at the moment it is mixing and matching both with all the sound issues reported on the forums associated with it.

I can’t comment on when picroft might get some love from the devs again, but that might still be months away.

Me and some other amazing devs are working on an alternative for it. It’s for if you just want to use your rpi as ready to use device. It’s called OpenVoiceOS (started as MycroftOS). Anyhow, even we are running behind planning wise as it was planned to be released last weekend, so…

Anyhow; Know for sure it will be just a few more days, perhaps a week, but certainly not months. With that release we hope to release the pressure on the Mycroft dev’s related to picroft, so that all the current community members and all the new ones to come have an easy to use image again. That way the Mycroft Devs can stay focussed on their own priorities.

Bug reports that we receive for OVOS which are Mycroft related, we can then filter, fix and issues Pull Request to fix them. Bug reports that we receive for it it that are OVOS related are well, for ourselfs. Regardless, we as community can play around, test, fix, create where we as OVOS devs and ofcourse all community members can act as sort of filter for the Mycroft Dev team.

Less support calls, emails, bug reports for the Dev team means, more focus and faster work for them.

All I can say for now is; Hang in there…

1 Like

Thanks for the detailed response @j1nx .

My main goal was to make sure there was not an issue with my setup per se, looks like that’s not the case.

I’ve been tracking at your work with OpenVoiceOS fora while and was considering trying it out with my setup as I have a display attached to my RPi in a nice case.

@Charles, what version of picroft are you currently using? (I’m using 20.8.0). Looks like it’s working well with your raspiaudio, is it also a MIC+?

I’m running 20.8.0. I use a homemade audio bonnet with an I2S amp and an I2S microphone from Adafruit.

1 Like

@j1nx

I’m testing the alpha7 for 32bit of the OpenVoiceOS audio is working fine again, but no MIC.

If I try to test the microphone I’m getting:

mycroft@MycroftOS:~ $ arecord -d 10 test.wav
ALSA lib confmisc.c:767:(parse_card) cannot find card ‘0’
ALSA lib conf.c:4568:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4568:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1246:(snd_func_refer) error evaluating name
ALSA lib conf.c:4568:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:5047:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2564:(snd_pcm_open_noupdate) Unknown PCM dsnoop
arecord: main:828: audio open error: No such file or directory

mycroft@MycroftOS:~ $ alsamixer
cannot open mixer: No such file or directory

mycroft@MycroftOS:~ $ mycroft-start audiotest -l
-sh: mycroft-start: command not found

mycroft@MycroftOS:~ $ cat /home/mycroft/.asoundrc
options snd_rpi_googlevoicehat_soundcard index=0

pcm.softvol {
type softvol
slave.pcm dmix
control{
name Master
card 0
}
}

pcm.micboost{
type softvol
slave.pcm dsnoop
control {
name Micro
card 0
}
min_dB -10.0
max_dB 50.0
resolution 256}

pcm.!default {
type asym
playback.pcm “plug:softvol”
capture.pcm “plug:micboost”
}

ctl.!default {
type hw
card 0
}

Any pointers to make this mic work?