Picroft 2018-09-12 and the Google AIY Voice Hat


#21

Great to hear you got him working……But the process is not easy.

I did notise that alsamixer were at zerro to - so adding to the script to set it to 75% would be a good idea.
I dont understand why you nedded /home/pi/mycroft-core/dev_setup.sh as I remember that that to is done in the scrpt. I did when I did run it…Strange.

I think the picroft scrit could benefit from a rewrite, so installation of hardware were in differet scripts one for every hardware one will write installation for.
That would make the installation of picroft simpler - get mycroft up and running, and then add hardware. But that is just my opinion.


#22

I did add the 75% to
/home/pi/audio_setup.sh

#!/bin/bash
# Use this script to execute audio setup actions
sudo amixer cset numid=3 "1" > /dev/null
# amixer set PCM 99%
amixer sset Master 75%

Now sound is working at boot time :slight_smile:


#23

In picroft-google-aiy-voicekit.andlo/_init_.py, create_skill() creates a new PicroftGoogleAiyVoicehat, but the class is PicroftGoogleAiyVoicekit so loading the skill fails - last word is ‘hat’ vs ‘kit’


#24

edited to say: had to add the master fix to the audio setup script. meh.


#25

I got my AIY kit working, but only when I signin to it. There are no mycroft scripts in /etc/init.d/

What do I need to do to get the startup scripts?

One thing I had to do (like guidol did above) was modify /home/pi/audio_setup.sh to have “amixer set Master 75%” I had to do this as I had no PCM controls (used “amixer scontents” to see what I do have).


#26

Hi there @sixlinux, welcome, it’s great to have you here.
We pushed a commit yesterday which is designed to address several AIY kit issues.

Are you able to update your Picroft - a reboot should do it - and see if that addresses the issue?


#27

Reboot did not fix it, still nothing in /etc/init.d


#28

Reboot did not fix it. I tried imaging a SD card from picroft 2018-09-12, and it did not have the /etc/init.d scripts still. This time I selected option 1 for the audio setup and I got a PCM decvice. After that, the audio still did not work and I got the same error as others regarding the "aiy-python-wheels: protobuf not supported on armv6.1.

So I started over again:
I imaged a SD card from picroft 2018-09-12
I selected 1) Speakers for the audio
Audio test does not work, but continue since that is fixed later
I selected 3) Google AIY

I did a cntl c as soon as it tried to run mycroft (to prevent it from loading “aiy-python-wheels”).
Then I ran andlo’s script: “https://raw.githubusercontent.com/andlo/picroft-google-aiy-voicekit-skill/master/install_AIY.sh” This takes awhile, then reboot.
I also did a mycroft-msm install picroft-google-aiy-voicekit in order to get the button to work.

Still nothing in /etc/init.d, so mycroft services do not start unless I signon to it.


#29

Ok, waited awhile, rebooted, it did updates, now working!