Mycroft Community Forum

[Picroft] American Female Voice Not Working

I can select 4 voices on the Devices page - British Male, American Female, American Male, and Google Voice. I see those changes reflected when I run “mycroft-config show remote” - “ap” for British Male; “trinity” for American Female, “kusal” for American Male, and a bunch of TTS changes for Google Voice.

One thing I did notice is that when I make the change to American Female (no matter the previous setting), and say “Hey Mycroft; Configuration Update” it always replies that there are no changes to apply event though running “mycroft-config show remote” does show the change to “trinity” (see below for TTS section of config files after change to American Female).

mycroft-config show default
"tts": {
  "pulse_duck": false,
  "module": "mimic",
  "mimic": {
    "voice": "ap"
  },
  "mimic2": {
    "lang": "en-us",
    "url": "https://mimic-api.mycroft.ai/synthesize?text=",
    "preloaded_cache": "/opt/mycroft/preloaded_cache/Mimic2"
  },
  "espeak": {
    "lang": "english-us",
    "voice": "m1"
  }
},

mycroft-config show remote
"tts": {
  "mimic": {
    "voice": "trinity"
  },
  "module": "mimic"
},

mycroft-config show system
"tts": {
  "mimic": {
    "path": "/home/pi/mycroft-core/mimic/bin/mimic"
  }
},

Additionally, I saw a few other topics from several months ago that addressed this, but they didn’t help.

I got the following from Support…

An indication of this would be nice on the settings page (either a warning or have the selection box greyed out and un-selectable).

Hi Andy, thanks for the nudge, I’ve removed the American Female button from the interface until the new model is deployed. Note that it may still show for a short time due to caching in your browser.