Build an open future with us.

Invest in Mycroft and become a community partner.

PiCroft and AIY Voice kit


#1

I am guessing since I am getting no sound or anything from speaker, that you cant just plug the SD card image into the AIY voice kit and have Mycroft work? you have to do something to get mic and speakers to work?
Can anyone point me in the right direction in getting mike and speakers working or should they be working right away?

Got through the login and registration no problem, display says Mycroft is running but no sound

Thanks in advance


#2

There is some more work to be done to get it working. You’ll find all info in this thread. including some code I ported to use the button.

picroft-issue-with-pairing

I am thinking about building an image, that has everything setup right, but it will probably take some time.


#3

Try this disk image :wink:

Tjoen


#4

TY tjoen

I’m trying but I have a problem with sudo password…

is it not the usually? raspberry


#5

ok… found

sorry :sweat_smile::sweat_smile::sweat_smile:


#6

everything works perfectly!

Just… a reboot was necessary because the first time it said the pairing code only once and did not accept other commands. (also cli commands)

but after reboot it has regularly told his code and is now registered.

thanks a lot!


#7

Yeah, I had the same experience in the latest test. Could not figure out why.
Might be the update to 0.9.12 happening while booting…?
Not quite sure.

But 0.9.12 also seems to run fine.
Glad you liked it!

Tjoen.


#8

No it’s still 0.9.10

light&button work well :ok_hand:

backup_my_pi does not seem connected to a skill, is it used only by cli ?

yesterday I installed the internet radio skill, but on Home skill section is not yet detected

when backup is completed, i’m going to update 9.12


#9

WOW

Shrunk /media/usb/mycroft_Backups/backup_20171226_153420.img from 15G to 3.7G

20 minutes well spent

ty
Ale


#10

Yeah, I still have to put the backup and auto-dj into a skill wrapper. Till that time you can run the backupskill command through ssh, be sure to connect a usn ntfs formatted drive. Pretty handy indeed…

And manageable, for backups.

sudo apt-get upgrade should give you the new mycroft version.

A chromecast / sonos script is also present in the homedir. On a connected (ntfs) usb drive, create a folder with mp3’s with your music called ‘MUSIC’ (in capitals).
Also change the array in streamchromecast.py:

# Bands for the  google search
bands = ['Beastie boys','Prince','Bob Marley',  'Muse', 'Led Zeppelin', 'Howlin wolf', 'Kaiser chiefs', 'The Strokes', 'Rolling stones','De jeugd van tegenwoordig', 'editors' , 'rockpalast', 'etta james']

with bands that you like, It will play video’s and your music on the chromecast,
Or just your music on the sonos.

pi@picroft:~ $ python streamchromecast.py
Looking for music files
4883 files found
DeviceStatus(friendly_name=u'Beneden', model_name=u'Chromecast', manufacturer=u'                                                                                        Google Inc.', api_version=(1, 0), uuid=UUID('47195925-8859-4226-8827-35db8433ee1                                                                                        b'), cast_type='cast')
CastStatus(is_active_input=False, is_stand_by=True, volume_level=1.0, volume_mut                                                                                        ed=False, app_id=u'E8C28D3C', display_name=u'Backdrop', namespaces=[u'urn:x-cast                                                                                        :com.google.cast.debugoverlay', u'urn:x-cast:com.google.cast.cac', u'urn:x-cast:                                                                                        com.google.cast.sse'], session_id=u'63923cb1-d69a-4dd8-b30b-39a0391f4291', trans                                                                                        port_id=u'63923cb1-d69a-4dd8-b30b-39a0391f4291', status_text=u'')
No sonos found!
Start HTTP server

 Etta James - Something's Got A Hold On Me (Live) - YouTube
 Editors - Papillon - YouTube
 De Jeugd Van Tegenwoordig - Watskeburt?! - YouTube
 The Smiths Live at Rockpalast, Hamburg (1984) - YouTube

Create your own christmas playlist :wink:

Tjoen


#11

I also don’t get any skill info on the home portal. Just the default ‘Sorry, you don’t have skills to configure’


#12

hi tjoen

Can you update the location and setting (for time and data) on picroft using the basic settings in home?
I cannot set basic parameters or download a new voice

if I try to set the basic settings at home + update the configuration … nothing changes

Configuration updated.
Currently 11:05 AM
I’m in Lawrence, Kansas, United States

I abandoned the radio skill: I can not stop the radio easily, the microphone and speaker maybe too close and the wake word is not detected


#13

It sometimes did update, but did not work to great for me.
I’ve changed my config in the config file in /home/mycroft/,mycroft/mycroft.conf to:

{
  "tts": {
    "mimic": {
      "path":"/usr/local/bin/mimic"
    }
  },
  "SkillInstallerSkill": {
    "path": "/usr/local/bin/msm"
  },
   "location":{
      "city":{
         "code":"Oegstgeest",
         "name":"Oegstgeest",
         "state":{
            "code":"ZH",
            "name":"South holland",
            "country":{
               "code":"NL",
               "name":"Netherlands"
            }
         }
      },
      "coordinate":{
         "latitude":52.160114,
         "longitude":4.49701
      },
      "timezone":{
         "code":"Europe/Amsterdam",
         "name":"Central European Time",
         "dst_offset":3600000,
         "offset":3600000
      }
   }
}

That seems to work

The radioskill (and other skills that use the stop command) can also be stopped by pushing the button.
It send out a stop command on short presses.

Longer presses will cause the mycroft to start listening.


#14

you always have the perfect answer!

Thank you very much


#15

Hi
Has anyone managed to get the “stop” command to work?
On the AIY with Picroft I have to press the button because the wakeup words “hey Mycroft” are not recognised during any play skill, such as Internet radio or alarm etc.
Is there a setting somewhere to make it listen during playback so that I don’t need to cross the room to press the button?
Thanks


#16

The problem seems that the mic is to close to the speaker in the cardboard design. It doesn’t pick up the speech when playing audio output, unless you are really close and almost shouting. I implemented the stop by sending a stop command on the websocket when you press the button.

The mopidy skill lowers volume first and then listens for the (stop, or other) command. But in tests I found that the raspberry would listen to itself, and then lower the volume, while playing the songs.

I’m not sure what the way to go would be here, maybe use some isolation on the speakers back, or seperate the speaker by using a longer chord? We are currently looking into a custom 3d printed enclosure that separates the mic and speaker better. by changing it to the back, so not on the same side as the speaker.


#17

Thanks tjoen
I’m using a long cord microphone, so I have control of that and it still won’t trigger the stop command. Using the button works fine so I think there is something broken in the stop skill.