Mycroft Community Forum

Picroft and Home Assistant

I installed the picroft image on a Rpi 4 and the home assistant skill. I can tell mycroft to turn on/off lights. Is there any instructions for having HA send notifications to mycroft? Like when the front door opens mycroft would say “the front door is open” Iv’e add the mycroft: and host: “mycroftip” in HA configuration.yaml per HA instructions but it doesn’t show up as an notification service/channel in HA. Thanks.

2 Likes

If you try the mesh skill, you can send mqtt messages from home assistant to mycroft and mycroft will respond accordingly.

After entering

mycroft:
  host: <ipaddress>

to confuguration.yaml you need to restart Homeassistant. Then loog in homeassistant.log if there is some errors.

mine says:

~ $ cd config
config $ cat home-assistant.log |grep mycroft
2020-02-19 19:25:04 INFO (MainThread) [homeassistant.setup] Setting up mycroft
2020-02-19 19:25:06 INFO (MainThread) [homeassistant.setup] Setup of domain mycroft took 1.9 seconds.
2020-02-19 19:25:08 INFO (MainThread) [homeassistant.components.notify] Setting up notify.mycroft
config $ 

so there should be an notify.mycroft. But just as you - there isnt :frowning:

I dont think that is in he mycroft “end” but more likely the mycroft integration in Homeassistant.
Looking at the code in the integration, I notised it requere mycroftapi==2.0. And that is from 2017. Dont know yet if there is changes in mycroft-core that makes mycroftapi to break. And the maintainer seems to have left the “party” and deleted his reposotory.

Here is how i finally got it working.

mycroft:
host: 10.1.45.32
notify:

  • platform: mycroft
    name: picroft
2 Likes

No dot before platform.
-platform: mycroft
name: picroft
Format screwed up above when I said reply

1 Like

confirming - that works. Great :slight_smile:
Wondering if one could add more mycroft devices thou. I think like this

mycroft:
  host: 10.1.45.32
  host: 10.1.45.33
notify:
  - platform: mycroft
      name; picroft1
  - platform: mycorft
      name: mark_1

that I have to try :slight_smile:

1 Like

This works in my testing…
image
This also works with the MQTT “Mesh-Skill”
image
The MQTT “Mesh-Skill” notifies you where the message was sent from: “Home Assistant”

I will look at this. Thanks!

I am a newbee here, thanks, it works also for my project, Home Assistant 106.6 and Picroft 20.2.1, latest version.

2 Likes