Build an open future with us.

Invest in Mycroft and become a community partner.

Picroft Audo Setup for 9/12/2018 image


#1

Hi there,

When I first started using the 9/12/2018 picroft image, I had issues configuring the audio. Initially the microphone didn’t work, and then, once I installed pulseaudio as was recommended by members of the community, my pi was silent. I just fixed my problem and I wanted to share the solution that worked for me. After installing mycroft on the pi and running the standard updates, I got to the command line and typed:

sudo apt-get install pulseaudio

This installed PulseAudio. For me, this fixed the issue that my microphone didn’t work, but my speakers had gone silent. To address this, I typed “alsamixer” and in the settings menu that appeared I set the master volume to 90%. After testing this function to confirm that it was working I edited the audio_setup.sh file in /home/pi so that these settings would run whenever the pi started. I included the following line at the bottom of the script:

amixer sset 'Master' 90%

Now the audio volume for my Mycroft is automatically set to 90% upon load.

I have a working Picroft. I hope this helps others who encounter the same issue.

Derek


#2

Thanks for the tips @DerekCaelin, and great to see you around!

We recently pushed a commit that should install pulseaudio as a dependency, so that should make things a bit easier.

Do you think it makes sense to include your amixer configuration in the enclosure-picroft itself?


#3

Hi @KathyReid,

I think so. Literally all I’ve done to get Picroft working has been to install pulse audio and modify my audio_setup.sh. I also increased the volume for my own mic but that may not be necessary for others with a different setup.

#!/bin/bash
# Use this script to execute audio setup actions
sudo amixer cset numid=3 "1" > /dev/null
amixer set PCM 99%
amixer sset 'Master' 90%
amixer sset 'Capture' 80%

I hope it helps.

Derek