Picroft fresh boot - only two skills load


#22

Sorry, I meant the command line client, not the console.


#23

Well that’s interesting you can add the stable repo with:
echo "deb http://repo.mycroft.ai/repos/apt/debian debian main" >> /etc/apt/sources.list.d/repo.mycroft.ai.list

then rerun mycroft-use stable

To be honest, I’m not sure what the effect of fully removing the volume skill would be. To test that you’d need to run mycroft-msm remove mycroft-volume.mycroftai
and as it’s a default skill, to stop it returning you can add it as a blacklisted skill to your mycroft.conf
"blacklisted_skills": ["mycroft-volume.mycroftai"],


#24

Good news! I was able to get other skills to load.

I disabled the volume skill by removing from the priority skills. It seems like picroft only wants to load the priority skills, so I put count and mycroft-weather in priority, and both loaded successfully.

However, I did have to re-delete the .skills-repo first. For some reason, even when I reboot it does not reload skills; rather deleting the .skills-repo is the only way to change what is loaded.

Notably, even though both skills claim to have loaded, only the weather skill is working. When I try the count skill, I get the “please wait a moment” message along with the ‘failed to find intent’ error.

Thanks for all the help! I’ll try and figure out the remaining issues and post later.


#25

That is good news. But it is sertenly strange that you cant get a picroft to boot up without problems.


#26

Yay for progress!

It does sound like there’s some more fundamental problems happening though. If you have a spare micro SD card it would be great to try a fresh image and see if you have the same problem.


#27

I do have an old SD I flashed with the unstable version (18.8.11), which is where I originally was having the issues. I tried the same fix on it, which worked. Additionally, the skills log looks very similar.

For comparison:
(unstable) skills.log: https://pastebin.com/wZ6p2X6L
(stable) skills.log: https://pastebin.com/nfinfyi9

The similarities seem to be:

  1. the many git.cmd calls
  2. messagebus.client.ws calling remove and on_error
  3. the python exception in skills_manager.py at the end of the log:
    “AttributeError: ‘MycroftSkillsManager’ object has no attribute ‘lock’”

I’m pretty sure #2 is just the web-connection issue, but #3 seems potentially relevant. I’ll have to track down msm.lock (the attribute which apparently does not exist) since I couldn’t find it last time I looked into mycroft-core.

Also, it doesn’t seem like the issue is with the volume skill, since I was able to get the other skills to load without disabling it.


#28

I think focus should be on the ERRORS in the log

20:43:26.341 - mycroft.skills.settings:_poll_skill_settings:389 - ERROR - Failed to fetch skill settings: FileNotFoundError(2, 'No such file or directory')
20:48:13.622 - mycroft.messagebus.client.ws:on_error:76 - ERROR - === ConnectionResetError(104, 'Connection reset by peer') ===
20:48:13.639 - mycroft.messagebus.client.ws:on_error:83 - ERROR - Exception closing websocket: Exception("Uncaught 'error' event.",)
20:48:13.651 - mycroft.skills.skill_manager:stop:526 - ERROR - Shutting down skill: /opt/mycroft/skills/mycroft-version-checker.mycroftai
20:48:13.701 - mycroft.skills.skill_manager:stop:526 - ERROR - Shutting down skill: /opt/mycroft/skills/mycroft-audio-record.mycroftai
20:48:13.707 - mycroft.skills.skill_manager:stop:526 - ERROR - Shutting down skill: /opt/mycroft/skills/mycroft-configuration.mycroftai
20:48:13.751 - mycroft.skills.skill_manager:stop:526 - ERROR - Shutting down skill: /opt/mycroft/skills/count.andlo
20:48:13.816 - mycroft.skills.skill_manager:stop:526 - ERROR - Shutting down skill: /opt/mycroft/skills/mycroft-weather.mycroftai
20:48:13.822 - mycroft.skills.skill_manager:stop:526 - ERROR - Shutting down skill: /opt/mycroft/skills/mycroft-date-time.mycroftai
20:48:13.864 - mycroft.skills.skill_manager:stop:526 - ERROR - Shutting down skill: /opt/mycroft/skills/mycroft-pairing.mycroftai

``Mainly the first ERROR found looks interesting.
following that line is this:

  File "/home/pi/mycroft-core/mycroft/skills/settings.py", line 382, in _poll_skill_settings
    self.initialize_remote_settings()
  File "/home/pi/mycroft-core/mycroft/skills/settings.py", line 156, in initialize_remote_settings
    self.save_skill_settings(skill_settings)
  File "/home/pi/mycroft-core/mycroft/skills/settings.py", line 224, in save_skill_settings
    self._save_uuid(skill_settings['uuid'])
  File "/home/pi/mycroft-core/mycroft/skills/settings.py", line 259, in _save_uuid
    with open(uuid_file, 'w') as f:
FileNotFoundError: [Errno 2] No such file or directory: '/home/pi/.mycroft/skills/TimeSkill/uuid'

Why a fresh install should have this kind of errors i dont understand…but could be that you earlier had a working mycroft, and had used the timerskill to set an alarm?
And maybe that setting is tored on home.mycroft.ai and at initialasion is fetched down, and as the timerskill isnt yet installed and setup tehre is an errro.

If that is the reason - then try make making the directory /home/pi/.mycroft/skills/TimeSkill/ and restart mycroft.


#29

I have opened a issue on mycroft-core about this error. #1986 https://github.com/MycroftAI/mycroft-core/issues/1986

I also did try to make a PR that could fix it, but I am not that good githubber so cant figure out how to do that without also making a PR with other changes :frowning:

Please let us know if adding the directry helped in any way.