Picroft install problem


#1

Hey Mycroft
I physically broke the first Micro SD card and am trying to give picroft another drive to live in. After flashing the disk it does not want to boot into the CLI and just hangs at the terminal prompt. A pasting of the terminal is attached. This is the second time I have flashed it with raspian-stretch_Picroft_2018-09-12.zip and I seem to get the same problem.
Look forward to hearing what ails him.
Thanks for reading, and any answers

Installing packages…
E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
Initializing…
Starting background service bus
CAUTION: The Mycroft bus is an open websocket with no built-in security
measures. You are responsible for protecting the local port
8181 with a firewall as appropriate.
Starting background service skills
Starting cli
Traceback (most recent call last):
File “/usr/lib/python3.5/runpy.py”, line 183, in _run_module_as_main
mod_name, mod_spec, code = _get_module_details(mod_name, _Error)
File “/usr/lib/python3.5/runpy.py”, line 109, in _get_module_details
import(pkg_name)
File “/home/pi/mycroft-core/mycroft/init.py”, line 17, in
from mycroft.api import Api
File “/home/pi/mycroft-core/mycroft/api/init.py”, line 26, in
from mycroft.identity import IdentityManager, identity_lock
File “/home/pi/mycroft-core/mycroft/identity/init.py”, line 21, in
from mycroft.util.combo_lock import ComboLock
File “/home/pi/mycroft-core/mycroft/util/combo_lock.py”, line 16, in
from fasteners.process_lock import InterProcessLock
ImportError: No module named ‘fasteners’
(.venv) pi@picroft:~ $ protobuf-3.6.1-cp35-cp35m-linux_armv6l.whl is not a supported wheel on this platform.
dpkg: error processing package aiy-python-wheels (–configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
aiy-python-wheels
E: Sub-process /usr/bin/dpkg returned an error code (1)
Starting all mycroft-core services
Initializing…
Starting background service bus
CAUTION: The Mycroft bus is an open websocket with no built-in security
measures. You are responsible for protecting the local port
8181 with a firewall as appropriate.
Starting background service skills
Starting background service audio
Starting background service voice
Starting background service enclosure
(.venv) pi@picroft:~ $


#2

This sounds strange. What is your hardware platform? Do you use any soundcard/hat, e.g. Google AIY?


#3

Thanks for reply
I have a Raspiaudio pi hat which has been working in other incarnations (all on RP3 b+). Should I just install the driver and pulse audio?


#4

So you have a RPI 3B+ with this?

Then I think you ran into this issue Picroft 2018-09-12 and the Google AIY Voice Hat


#5

Yes, that is the hat, but I don’t see what the solution is.
Is there another image I should flash?
Thanks


#6

You can try to use a plain Raspbian Stretch image and do a git-install of Mycroft, but then you have to install and configure the soundcard driver manually.

Maybe @andlo can help, he is the author of the Google AIY Voicekit skill and a lot of experience with that…?


#7

Please Mycroft.
I am very confused. I have downloaded many, many picroft files. Some don’t seem to be flashable, others I can flash onto a disk and work sometimes and othertimes not. And now it seems I need a special one for the audio hat that I have, that used to work on one of the images I downloaded after Xmas. Can somebody point me to something that will work?
It is all very complicated for an old fool


#8

I dont know that specifik hat. But as Picroft is based on raspbian it should be posible to get it to work. But not out of the box.

First flash the ibage pointet to earlier.
Boot the Pi up on that image and log in (either by ataching a screen and keyboard or by ssh to picroft) userbame is pi and password is mycroft.
Follow the guide to install everything - under voice you dont have option for your specifik hat, so just select none (the last choice as i remember)
Then mycroft should start up…and first he wants is to update. Let him do that for a while.
Then exit the cli by Ctrl+x
Update the raspbian by sudu apt-get update and sudo apt-get upgrade
reboot the device after update and log in again.
Mycroft should start up in the cli and you should be able to pair ant write to mycroft. Sound andmic maybe not work yet.
When paired and it feels like he is working ecit the cli by ctrl+x
follow the install instructions supplyed by raspaudio https://www.raspiaudio.com/raspiaudio-aiy/
boot your device when done
Then maybe sound and mic is working else we have to look into what to do…
What could be needed is:
install pulseaudio by sudo apt-get install pulseaudio

  • change asound.rc in /etc (dont know yet to what, but could be something like the changes on the google voice hat)
  • set volume up from zero by using alsamixer

But first thing is getting the picroft running and updated. Then we lookinto how to get that specifik hat working :slight_smile:


#9

Thanks very much for your detailed reply, but I am still not sure which image to flash.


#10

That should be the one linked from here

direct link to download here

That is the one I use, and today just did a reflash of one of my pi’s


#11

Thanks so much for the all the above information.
Mycroft is now working. He is fantastic
Keep up the amazing work
Thanks again


#12

Great to hear. did you manage to get the voicehat going aswell?


#13

Yes, he’s all working and very chatty.
Thanks again


#14

Following on from this. I am not sure the mic is set up properly. When I record and play back through Picroft the sound quality is very poor. If do arecord and aplay from the command line the quality is much better. I have played with the alsamixer settings but it does not seem to improve.
Any thoughts anyone?
Thanks