Build an open future with us.

Invest in Mycroft and become a community partner.

Picroft just not working


#1

Hey Mycroft
I have loaded picroft onto raspberry pi twice now and each time I get a similar audio problem. The pi has a with a seeed pHat for speakers and mic. I think it is to do with alsa not saving settings for pycroft, but my skills are limited. Both the mic and the speakers work with arecord and aplay. I don’t have much more patience I’m afraid.
Sorry


#2

Hi @aaron57
I am sad to hear you cant get it to ork. Just remember using picroft isnt like a LEGO building set, where everything is in the box and you just have to follow one easy instruction. No.
it is many different parts each with own instructions, and the glue that puts all that together is the users patience.

Picroft is a Raspbian preinstalled with mycroft to get an easier start.

If your problem is that it chooses wrong output, you could disable the builtin audio on the Pi by edit config.txt and set dtparam=audio=off

Otherwise looking at raspberrypi.org forum I found this about something simaly
https://www.raspberrypi.org/forums/viewtopic.php?p=1176001
maybe that is a starting point for you to figure out how and what and then glue everything together with your patience.

And if you really dosnt have patience, there are alternatives where you dont need that, they work out of the box and only for a small price like missing privacy and missing hackabality.


#3

Hi @aaron57, sorry to hear you’ve had a poor experience.

There are a couple of things to try here;

  • Try installing pulseaudio using sudo apt-get install pulseaudio
  • try using sudo alsamixer instead of alsamixer. This can help esure the setting changes “keep”