Mycroft Community Forum

PIcroft not responding to mic

I have successfully installed PIcroft on a PI3b+ with respeaker 2 hat. All of the audio in and out is working correctly when running mycroft-start audiotest but it wont respond to the wake word and there is no activity on the mic, see picture.


Can anyone tell me where to look next?

I think I ended up playing with alsa settings before I could get it to work for me…

You might have to set up a udev rule


echo 'SUBSYSTEM=="usb", ATTR{idProduct}=="0018", ATTR{idVendor}=="2886", MODE:="0660"' | sudo tee /etc/udev/rules.d/60-respeaker.rules &> /dev/null

toss /etc/udev/rules.d/60-respeaker.rules if this wont work.

EDIT: Just realised your talking about a HAT, so i don’t know how the signal is bussed.
This commit (unrelated) might give you some ideas. So basically i think it’s a permission issue