Build an open future with us.

Invest in Mycroft and become a community partner.

Picroft problem


#1

Hi Mycroft
I have just tried to get picroft to work ( I still do not have a mike or a speaker).
I can get him to to boot and am seeing code on the telly screen, but I can’t get him to do anything. I have SSHed into it from a laptop so I guess it is connected to internet. It says that I should see the contents of the speech log but nothing is happening. it also says to ./dev_setup.sh, but when I try it goes ‘No such file or directory.’ All I have is the picroft command prompt and a flashing curser.
Any Ideas what is wrong
Christmas can be a little disappointing sometimes!
Cheers
Aaron


#2

Hi @aaron57, can you post a screenshot or a photo of what you see on the screen? Picroft is designed to be used with a mic or speaker; you will have a much better experience with a mic and speaker.


#3

Hi Kathy
Thanks for your reply. Here is a screenshot of my picroft! mycroft%20problem%20screenshot|432x499
I will get mike and speakers as soon as, but am curious to see what its all about!
Hope you can open the png
Cheers
Aaron


#4

Hi @aaron57 unfortunately when I click on the link to the .png, it doesn’t open, I don’t suppose you could try uploading it again?


#5

Hope this is better


#6

Thanks, that’s super useful.

Can you run the command ls -las and send me another screenshot?
I’m a little concerned because the ./dev_setup.sh file should be in that directory.


#7


#8

OK, we’re going to run update.sh instead.

Can you please try:

bash update.sh

and let me know how you go?


#9


I have another screenshot for you. I got some kind of update, and it looks more like the mycroft I have seen before, but it is constantly disconnecting and connectiong and is not responsive.


#10

oops sorry.
this is the screen shot of the reconnection error


#11

Thanks @aaron57, these errors are seen when mycroft services are not running and the mycroft-cli tries to connect.

Can you reboot Picroft (easiest way is to disconnect and reconnect the Micro USB cable) and see if that boots into the CLI?


#12

Yay Kathy
You’ve sorted him
Thanks so much for you time and effort on what should be a holiday, even for artificial intelligence
Aaron


#13

You’re very welcome! We’re here help :slight_smile:


#14

The ./dev_setup.sh file is in the mycroft-core sub-file.
Also from mycroft-core ‘./start-mycroft.sh debug’ will restart all the mycroft services.