Picroft venv errors


#1

Hello,

after the last big update I seem to be having some problems with my Picroft.
Firstly I want to mention that my Picroft is running headless on a RPi 3B+.
Most of the skills work as they normally should butI have noticed that I am having this error in the log output of the venv all the time, even after restart and so on.


More so I seem to be having issues with removing or adding skills from the marketplace or editing the skills from the device installed skills page.

I have tried doing the configuration update by voice and it said it is up to date, tried running the bash update.sh, but no change.

I hope you can give me a hint at what I can do to fix these small issues.
Thanks in advance and keep on the good work!


#2

Hi, the Marketplace is currently semi-broken and installs doesn’t actually work.

The issue you’re experiencing looks like the backend (or one of the skill settings) are returning an unexpected value in a field. I don’t think it would block the skill fetching for all skills but maybe?

You could try to switch to the dev branch (git checkout dev ) where the skill settings don’t use that endpoint any longer, instead uses a modernized version.


#3

For Skill installs, the best way is to just ask Mycroft eg “Hey Mycroft, install skill name
Or if you are ssh’d into the device you can use the commandline:
mycroft-msm install skill-name

The error in your screenshot was recently identified and fixed which is currently available in the dev branch but we are hoping to release the new Mycroft core in the next day, so if you have updates allowed this should resolve itself :slight_smile:


#4

Thank you for the swift answers, about the marketplace, it’s ok, glad to know that it is not just broken for me. As for the error then, I will probably wait for the dev branch to become master, since my Picroft does work even with the error being shown.