Problem with SSH? New User

I just installed the latest Mycroft on my Raspberry Pi 4 and everything seems to
work perfectly. I asked Mycroft for the IP address too it to CMD panel and typed
ssh @pi and my number and it would not connect? Is there a place to go to correct this? Thanks

@K5BBoing - Can you ping the IP address?
Did you do ‘ssh @pi:IP.address’, or ‘ssh pi@IP.address’. The latter is what you want.

-Mike M

yes I did the latter, just tried it again and it said no connection timed out?

this time I tried it again and it gave me a warning host key has changed? what does that mean? I think I left out a 1 in the middle but now it gives me this error?

Try ‘ping <IP.address>’ - what does that report?

-Mike M

I did that 4 sent 4 received the IP address is correct but something else has gone sideways?
I put the correct IP address in and the correct format and it give me an error message
the remote host identification has changed?
It now says I need to enter the correct host key to get rid of the message?
Otherwise the only thing I can do now to shut off the Mycroft is just cut the power and there I run the danger of corrupting the card?

the other critical issue with the ability of having ssh is to update the system> I hope this does not mean I have to scrub the card and try again?


Can you attach a monitor and keyboard to the RasPi?

If you’ve scrubbed the card and booted from the same RasPi, I would expect that message. Can you just click or reply ‘yes’?

If you’ve scrubbed the card, you’ll get a new host key for the same MAC address. SSH is just reporting the change.

Hope this helps.

-Mike M

thanks for the help
yes I guess I will connect monitor and keyboard for the update, it is a shame I fouled the ssh option with some dumb mistake.
Last night I gave it the the verbal command last to turn itself off and that worked so I do not have to worry about not being able to shut it off with out a command line…

If it gives a warning of SSH key being changed, look for the corresponding entry in the known_hosts file. On a Linux machine, it is located at /home/USERNAME/.ssh/known_hosts

Not sure where it’s located on windows.

Thanks for the help, right now it has been doing fine with the verbal commands, at the end of the day I just ask it to turn itself off and it does, it also has the option of updating via voice commands which is great. Really been enjoying this thing.