Build an open future with us.

Invest in Mycroft and become a community partner.

Problems installing mimic on rhel 6.9


#1

The dev_setup.sh script flies along until it gets around to compiling mimic then it gets this error:

configure:12739: $PKG_CONFIG --exists --print-errors "icu-i18n"
Package icu-i18n was not found in the pkg-config search path.
Perhaps you should add the directory containing `icu-i18n.pc’
to the PKG_CONFIG_PATH environment variable
No package ‘icu-i18n’ found

I believe I have the icu stuff installed:

Package libicu-4.2.1-14.el6.x86_64 already installed and latest version
Package libicu-devel-4.2.1-14.el6.x86_64 already installed and latest version

But there’s no file icu-i18n* found.

Any suggestions?!

-Guy Daniels


#2

It looks like this is an issue with the default pkgconfig paths on RHEL. Take a look at this StackOverflow Answer. Specifically, you can try running export PKG_CONFIG_ALLOW_SYSTEM_CFLAGS=1 before ./dev_setup.sh. If it doesn’t look like that did anything, you can cd mimic/ and try manually compiling with the extra last two flags like:

./configure \
     --with-audio=alsa \
     --enable-shared \
     --prefix=$(pwd) \
     --with-system-libdir=/lib:/usr/lib \
     --with-system-includedir=/usr/include
make -j4
make install