Mycroft Community Forum

Question --mycroft_gui - to indefinite display

wondering is there a way to set mycroft-gui idle time period to indefinite that works better . as I built mycroft -gui skill that displays data visualization pages . that i would like to set as permanent display when activated.
example when I set it to this roughly one week to time out:

   override_idle=600000

it seams to affect all the time out periods universally to have a time out period of 600000. and it does not seam to matter if you set override_ride= 60 on the next skill. it seam to keep the the 6000000 timeout until until it is reached (i assume as never waited the week to see i wait 10 - 15 minutes though with out it timing out) for all the GUI skill timeouts

example skill

visualization of my database info on mycroft-gui


I verified my suspicions, I reduced the override_idle to 10 minutes . for my screen display . once the override_idle is activated all GUI skills maintain the same override_idle parameter. once it runs out then they will use their default timers. I even tried and setup a stop display request that set the idle time to None with in the monitor skill. it say in the CLI that the over ride timers have being disabled -but the timer continues until the original timer run out. I suspect it is a bug in the software and probably no work around currently

depending on the target platform instead of trying to override indefinitly you can set a page from your skill as a resting face by registering your skill as a resting_screen_handler and then show your visualization inside a custom “self.gui.show_page(‘idle.qml’)”