[RESOLVED] Start-mycroft.sh stalls at 'collecting gTTS==2.0.3'


#1

Hello. I’ve had quite a time trying to set up picroft. At the moment, I cannot get start-mycroft.sh to complete; it appears it’s stalling while trying to install gTTS.
After giving me a warning about python-coveralls requirement coverage, it proceeds to uninstall pip, no matter what version of pip it is, and install pip-18.0. It then gives me a warning about pip not being up to date. After a line about not finding a pre-commit file with grep, it looks like it starts going through requirements.txt, but it gets stuck on gTTS.

Requirement already satisfied: six==1.10.0 in ./.venv/lib/python3.5/site-packages (from -r requirements (line 1)) (1.10.0)
Collecting requests==2.20.0 (from -r requirements.txt (line 2))
    Using cached https://files.pythonhosted.org/packages/...../py3-none-any.whl
Collecting gTTS==2.0.3 (from -r requirements.txt (line 3))
    Using cached https://files.pythonhosted.org/packages/..../gTTS-2.0.3.tar.gz

And there it stays. I’ve tried letting it sit for a half hour and it doesn’t resolve.
It does this at boot, and it does this when I ctrl+c to get to the CL and go into mycroft-core and run ./start-mycroft.sh .
Also, when its running from boot, it prints everything twice.

Update: I’ve somewhat temporarily fixed it by commenting out the gTTS line in requirements.txt and installing it separately from the CL. I’ve yet to ever get picroft fully working so I’m not sure if this is a valid work around or not, but it seems like it should be. Once the line for gTTS is commented out, pip is able to go through the whole file fine.


#2

Hi Maejoh,

Sorry to hear about the trouble getting started with Mycroft.

Can I check, are you using the official Picroft image or starting with Raspbian and installing via git clone?

Installing it separately in the python virtual environment should be exactly the same, so yep definitely a valid work around. I wonder if the cached package was corrupted in some way?


#3

I’m starting with the official Picroft image. My guess is that the cached package was/is indeed corrupted, because doing “pip install gTTS” installs v 2.3.0 just fine, but doing “pip install gTTS==2.0.3” from the venv does the same thing, where it stalls and doesn’t go anywhere. But at least leaving out the version specifier works.


#4

Glad it’s working.

The other thing to try if anyone is reading this thread in the future is to add the -v flag to install to get more information about what it’s actually doing when it hangs ie:
pip -v install gTTS==2.0.3

The pip cache on Linux is located at: ~/.cache/pip
You can also force it to use the remote package with: pip --no-cache-dir install gTTS==2.0.3