Mycroft Community Forum

Run (audio ducking) shell script when Mycroft is listening to a command

So I see that Mycroft has issues with background noise:

An easy workaround from my perspective (since most often the noise comes from my computer) would be to have the ability for Mycroft to run a shell script both before and after it is trying to record my voice. This pair of scripts could pause and unpause music, or, even more simply, turn speaker volume off and then restore it.

Is this possible to implement?

Message Types - Mycroft AI (gitbook.io)
You can see here how to add events on different message types.

Also in the skill settings of home.mycroft.ai under volume control you can see a checkbox which enables/disables audio ducking.

I’ll take a look at the message types.

But I looked under skill settings and evidently audio ducking is enabled for me, but isn’t doing anything.

So - to be even more confusing - it started audio ducking for me today, though it wasn’t yesterday.

But to make things even more frustrating, it seems that mycroft keeps increasing my output volume out of nowhere, meaning that my music I am playing suddenly starts blasting at high volume. I turned off auto volume (which I presume is supposed to set Mycrofts output volume), but that did nothing - I eventually had to quit Mycroft to keep my volume from surging.

Any idea why my master output volume is being changed by Mycroft?

try uninstalling auto volume skill