Mycroft Community Forum

Self.get_response not prompting for answer

I’m not sure what happened, I’ve tried rebooting my machines, I’ve looked over the code, I can narrow it down to a single line of code as simple as:

result = self.get_response(“hello”)

and I’ll hear Mycroft say “Hello”, but it will not prompt me for a response. It’s almost like my microphone isn’t active or working; however it is because I can initiate the skill. Any ideas why this would all of the sudden stop accepting responses back?

Thanks,
Jay

Hi Jay,

Have you got the code in a repo we can take a look at?

The simplest way to see if the mic is being triggered is probably watch the CLI while you are running the Skill. The microphone and wakeword messages are displayed in bright green, so you’ll see something like:
__main__: handle_record_begin:37 | Begin Recording...

I actually just figured this one out a short while ago. Here’s how to reproduce it:

Works:

self.get_response(“Hello”)

Doesn’t work:

self.get_response("Hello ")

it seems like my strings had a space at the end and if there is a space there it was failing.

1 Like

Thanks for posting what you found, and glad you worked it out.

Strangely I’m not getting the same behaviour. Will have to do some more testing…