Mycroft Community Forum

[Solved] Can't create an account on home.mycroft.ai

Hello everybody, newbie here.

I want to create an account on home.mycroft.ai, however when I try I get the error message “An error occurred, account not added.”. I tried today and I already tried several days ago, with different browsers.
Here is the error on the browser’s Javascript console :

‘’’
Backend returned code 500, body was:

500 Internal Server Error

Internal Server Error

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.

'''

What am I supposed to do know ? Is there any way to get around this ?
Thanks for your help.

what steps are you using to reproduce this?

I finally solved the issue, seems that some browser-side connexions were blocked by Firefox/Vivaldi (even with all ad/cookies blockers disabled), even though the error message is about a server error. For some reason I decided to try with Safari and it worked. for a reason, Gmail email adresses do not work so I managed to create an account with another one.

Thanks anyway @baconator !

Here is ways to reproduce ;

  1. Open home.mycroft.ai
  2. Click on “create an account” (from “Need to create an account first?”)
  3. Enter an email adress and a password
  4. Accept the Terms of Use and the Privacy Policy
  5. Click on the “Create Account” button
  6. Get the error message “An error occurred, account not added.”

Alternate version (sign in with Github) :

  1. Open home.mycroft.ai
  2. Click on “create an account” (from “Need to create an account first?”)
  3. Click on “Log In with Github”
  4. Authorize the Github access
  5. Get sent back to the previous page, without any message

Trying to Log In :

  1. Enter credentials
  2. Click “Log In”
  3. Nothing happens
1 Like

Hi there, welcome to Mycroft and thanks for reporting the issues you ran into.

We have a lot of Gmail users so there must be something else going on. I’ll flag it with our team and see what we can find.

Glad you got setup in the end though :slight_smile:

1 Like

I don’t know if it’s related but home.mycroft.ai/api displays an “internal server error” page. At first I thought it was my host filter, but I couldn’t solve the problem by disabling it.

Hi, I have the same issue, and have this in my firefox :
Backend returned code 500, body was:

500 Internal Server Error

Internal Server Error

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.

main.97bd0c4df85faee34c10.js:1:260117 handleError https://sso.mycroft.ai/main.97bd0c4df85faee34c10.js:1 error https://sso.mycroft.ai/vendor.43a5375bba7dc616aa78.js:1 _error https://sso.mycroft.ai/vendor.43a5375bba7dc616aa78.js:1 error https://sso.mycroft.ai/vendor.43a5375bba7dc616aa78.js:1 _error https://sso.mycroft.ai/vendor.43a5375bba7dc616aa78.js:1 error https://sso.mycroft.ai/vendor.43a5375bba7dc616aa78.js:1 notifyError https://sso.mycroft.ai/vendor.43a5375bba7dc616aa78.js:1 _error https://sso.mycroft.ai/vendor.43a5375bba7dc616aa78.js:1 error https://sso.mycroft.ai/vendor.43a5375bba7dc616aa78.js:1 c https://sso.mycroft.ai/vendor.43a5375bba7dc616aa78.js:1 invokeTask https://sso.mycroft.ai/polyfills.fe2ee2d4ceefdcd961d7.js:1 onInvokeTask https://sso.mycroft.ai/vendor.43a5375bba7dc616aa78.js:1 invokeTask https://sso.mycroft.ai/polyfills.fe2ee2d4ceefdcd961d7.js:1 runTask https://sso.mycroft.ai/polyfills.fe2ee2d4ceefdcd961d7.js:1 invokeTask https://sso.mycroft.ai/polyfills.fe2ee2d4ceefdcd961d7.js:1 m https://sso.mycroft.ai/polyfills.fe2ee2d4ceefdcd961d7.js:1 k https://sso.mycroft.ai/polyfills.fe2ee2d4ceefdcd961d7.js:1