Build an open future with us.

Invest in Mycroft and become a community partner.

[SOLVED] Home Assistant - no settings in



I am running a new installation of Picroft.
I have installed the home assistant skill manually (msm install msm list tells me it is installed, however I cannot find the settings in

According to the git page, “This skill utilizes the skillsettings.json file which allows you to configure this skill via”… However I cannot find this file on my system, I am guessing that’s where the problem is.

Any ideas on how to fix this?



Ok… According to the log, the skill does not start (which explains why the settings area is not created on because the module fuzzywuzzy is missing.

After entering the virtual env (source /opt/venvs/mycroft-core/bin/activate) if I try to install it I get this:

(mycroft-core) pi@picroft:/var/log $ pip3 install fuzzywuzzy
Collecting fuzzywuzzy
Installing collected packages: fuzzywuzzy
Could not install packages due to an EnvironmentError: [Errno 13] Permission denied: '/opt/venvs/mycroft-core/lib/python3.4/site-packages/fuzzywuzzy'
Consider using the `--user` option or check the permissions.

(mycroft-core) pi@picroft:/var/log $ pip3 install fuzzywuzzy --user
Can not perform a '--user' install. User site-packages are not visible in this virtualenv.

Suggestions? I guess I need to be root but I’m not sure how to combine that with the virtual env.


Ok, problem solved lol… I just installed fuzzywuzzy with sudo outside of the virtual env, rebooted and the skill loaded, the settings are now present in my account…


A few things to check here;

  • Is Picroft paired successfully?
  • If you do a Shift + F5 refresh on does this help at all? uses some caching at the server level.
  • In the Skills log at /var/log/mycroft-skills.log are there any errors related to the Home Assistant Skill?

Best, Kathy


Hi Kathy
Thanks for the reply, but I have already solved that problem - fuzzywuzzy was not installed so as a result the skill was not starting at all, which is why the settings area had not been created.


Great detective work!


I’m getting used to this by now :stuck_out_tongue:


fuzzywuzzy solved this, maybe it should be included in the next picroft :slight_smile: