Build an open future with us.

Invest in Mycroft and become a community partner.

[SOLVED] Mycroft claims he needs to register, but he is kind-of on-line


#1

When I got home today, Mycroft was complaining that he needs to register. If I reboot him, he gets his settings for clock display and eye color, but continues to insist that he needs to register. If I let him sit long enough, he comments that something unexpected has happened and he needs to restart pairing.

He will react to his name, but does not appear to process commands.

Any ideas for something I can try? I am holding off on the obvious delete-and-reregister until I hear from someone who understands the system better than I do.


#2

We experienced a weird outage with our redis server which caused every device to unpair unfortuantely. :confused: you are going to have to repair the device. You can find more information on this issue here


#3

Oddly, I had to reset my password to get into https://home.mycroft.ai as well. Not sure if it was related or just a weird coincidence.


#4

Did a re-pair, Mycroft is working again. I wonder how long it will take before he figures out he’s not in Lawrence, KS. It is causing the time display to be an hour slow. Oh, well, it will catch up eventually.


#5

New hitch in the works. I cannot set the location for my device. Attempts to type in the location field produces italic text, but this cannot be saved, so Mycroft is convinced he is in Lawrence, KS.


#6

I found the problem. I’d ratcheted up the security settings a bit too high, I had to allow a script, then I could change location.


#7

I can’t log into the main mycroft.ai site (I can log into community.mycroft.ai fine) - did something happen to the user bindery or passwords?


#8

Hi there @jqh1234, we are tracking a bug with Facebook authentication to home.mycroft.ai. Can you please confirm which service you use to authenticate to home.mycroft.ai - ie. Facebook, GitHub, Google, or email?

Kind regards, Kathy


#9

I use an dedicated/isolated account on mycroft.ai with an email address as the username - so: email - same thing on community.mycroft.ai, except that my username is separate from the email address I supplied, I suppose.


#10

There was no impact to usernames, passwords or user bindings during the outage, the only impact, well, other than a service outage (!) were that the pairing tokens were invalidated. If you DM me your email address for logging in I’ll get my colleague @matheus-mycroft to check it out in the database. If you’d prefer to send it to me end to end encrypted, which is totally understandable, I’m @kathyreid on Keybase.


#11

He’s at it again. I got home yesterday, and the response to any command is to give me a registration code.

I’ve rebooted several times, and he just goes back into the registration loop, but he is getting display settings (Eye color, time display).

Do I have to delete and re-register again?


#12

Unfortunately it sounds like re-pairing is the way forward here. Pairing is done through a token mechanism and if the tokens are out of synchronisation then the unit will lose pairing with home.mycroft.ai. We are working on re-architecting this part of our infrastructure to make it more resilient to failure.


#13

Done. He’s back to normal. I’ve been using him as an alarm clock by specifying a run time (“Hey Mycroft, set an alarm for 7 hours from now.”). I’ll need a less-busy day to test if the time zone problem on an alarm time of the form 6AM has been fixed. I’ve been having him tell jokes and asking assorted questions. About half the questions about actors get a one-word answer that I can’t understand. It might be “full”, others sound like “date”.Every now and then I’ll get “Actor”.


#14

Thanks for confirming it worked, @mwgardiner. If you’re able to let us know which questions/answers aren’t working well we can have a look and see if the relevant fallback skill is working properly.


#15

Rather than keep this thread meandering, I’m starting a new one for the topic of non-answers on actor questions.