[SOLVED] Setting up Wit.ai as STT


#1

Hello,
I’m trying to setup Mycroft on my computer without using “Home” (ie. without a mycroft account).
I’d like to use Wit.ai as STT provider, but I can’t find a valid json example.

So far I have:

 "stt": {
    "module": "wit",
    "wit": {
      "credential": {
        "token": "My server access token got by creating a new app at wit.ai"                  
      }
    }

but it doesn’t work: as I write something in the Input box (in mycroft-core terminal) I get:

15:36:40.301 - QuestionsAnswersSkill - INFO - Timeout occured check responses

Any help please? thanks


#2

Fixed: the configuration I used was correct! The problem was a typo lol.

Thanks anyway


#3

@Luca1991 where did you find wit / mycroft documentation? I can’t make it work. Can you post here your full configuration?
Thanks


#4

Perhaps this would help you:
https://mycroft-ai.gitbook.io/docs/using-mycroft-ai/customizations/languages#setting-your-stt-engine


#5

Thanks @malevolent. I’ve already read this doc but i couldn’t help me with wit configuration.


#6

Hi @noaki22, can you post the configuration you have?

If you aren’t already using it, our new configuration manager has a built in JSON validator that catches a lot of problems we run into.


#7

sure it worth a try. thanks!